You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@lucene.apache.org by "Uwe Schindler (Jira)" <ji...@apache.org> on 2021/09/30 08:50:00 UTC
[jira] [Commented] (LUCENE-10137) Refactor DirectReader and remove
heavy code duplication
[ https://issues.apache.org/jira/browse/LUCENE-10137?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17422625#comment-17422625 ]
Uwe Schindler commented on LUCENE-10137:
----------------------------------------
I also changed the RuntimeException to the new UncheckedIOException.
> Refactor DirectReader and remove heavy code duplication
> -------------------------------------------------------
>
> Key: LUCENE-10137
> URL: https://issues.apache.org/jira/browse/LUCENE-10137
> Project: Lucene - Core
> Issue Type: Task
> Components: core/other
> Reporter: Uwe Schindler
> Assignee: Uwe Schindler
> Priority: Major
> Time Spent: 10m
> Remaining Estimate: 0h
>
> DirectReader creates a dozen of inner classes blowing up the JAR file that just contain the same code over an over.
> This issue will refactor DirectReader like this:
> - Let DirectReader implement LongValues directly
> - The LongValues get method is implemented by calling LongUnaryOperator functional interface
> - the LongUnaryOperator is a method reference to one of the new private getXY() methods, which are specialization for all supported bit sizes.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@lucene.apache.org
For additional commands, e-mail: issues-help@lucene.apache.org