You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@sqoop.apache.org by "Sqoop QA bot (JIRA)" <ji...@apache.org> on 2014/11/11 01:06:33 UTC

[jira] [Commented] (SQOOP-1703) Sqoop2: rename Type to Column Type + size to length + minor doc fixes

    [ https://issues.apache.org/jira/browse/SQOOP-1703?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14205611#comment-14205611 ] 

Sqoop QA bot commented on SQOOP-1703:
-------------------------------------

Here are the results of testing the latest attachment
https://issues.apache.org/jira/secure/attachment/12680693/SQOOP-1703.patch against branch sqoop2.

{color:red}Overall:{color} -1 due to an error

{color:red}ERROR:{color} Patch does not add/modifny any test case
{color:green}SUCCESS:{color} Clean was successful
{color:green}SUCCESS:{color} Patch applied correctly
{color:green}SUCCESS:{color} Patch compiled
{color:green}SUCCESS:{color} All tests passed

Console output: https://builds.apache.org/job/PreCommit-SQOOP-Build/581/console

This message is automatically generated.

> Sqoop2: rename Type to Column Type + size to length + minor doc fixes
> ---------------------------------------------------------------------
>
>                 Key: SQOOP-1703
>                 URL: https://issues.apache.org/jira/browse/SQOOP-1703
>             Project: Sqoop
>          Issue Type: Sub-task
>          Components: sqoop2-framework
>            Reporter: Veena Basavaraj
>            Assignee: Veena Basavaraj
>             Fix For: 1.99.5
>
>         Attachments: SQOOP-1703.patch, SQOOP-1703.patch
>
>
> {code}
> /**
>  * All data types supported by Sqoop.
>  */
> public enum Type {
>   ARRAY,
>   BINARY,
>   BIT,
>   DATE,
>   DATE_TIME,
>   DECIMAL,
>   ENUM,
>   FIXED_POINT,
>   FLOATING_POINT,
>   MAP,
>   SET,
>   TEXT,
>   TIME,
>   UNSUPPORTED,
>   ;
> }
> {code}
> this infact represent the column type in the abstract base class {code} Column{code}, Make it obvious.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)