You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@yunikorn.apache.org by "Wilfred Spiegelenburg (Jira)" <ji...@apache.org> on 2023/03/24 02:25:00 UTC

[jira] [Created] (YUNIKORN-1653) use iota instead of defined values for tri-state

Wilfred Spiegelenburg created YUNIKORN-1653:
-----------------------------------------------

             Summary: use iota instead of defined values for tri-state
                 Key: YUNIKORN-1653
                 URL: https://issues.apache.org/jira/browse/YUNIKORN-1653
             Project: Apache YuniKorn
          Issue Type: Improvement
          Components: shim - kubernetes
            Reporter: Wilfred Spiegelenburg


In the admission controller we have a tri-state that uses an integer as the underlying values. We should move to a iota that represents the same three values for clarity:
{code:java}
type triState int

const (
   UNSET triState = iota - 1
   FALSE
   TRUE
) {code}
Replace all the coded values with the triState values, store the triState and return it from function calls.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@yunikorn.apache.org
For additional commands, e-mail: dev-help@yunikorn.apache.org