You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tomcat.apache.org by "GAWLAS,JULIUS (HP-Cupertino,ex1)" <ju...@hp.com> on 2001/12/01 01:25:40 UTC

[PATCH] mod_jk for Apache 2.0 minor fixes

This patch contains minor fixes for mod_jk for Apache 2.0; 

Most important is the change in prototype of jk_post_config 
which used to be void but now needs to return success code, 
also changes to types of some variables to better confirm to 
Apache 2.0 types.

Let me know if you have any comments.

Julius 

Index: mod_jk.c
===================================================================
RCS file:
/home/cvspublic/jakarta-tomcat-connectors/jk/native/apache-2.0/mod_jk.c,v
retrieving revision 1.37
diff -u -r1.37 mod_jk.c
--- mod_jk.c	2001/11/21 00:09:21	1.37
+++ mod_jk.c	2001/11/30 23:58:13
@@ -110,9 +110,8 @@
 #define ADD_SSL_INFO    
 
 /* module MODULE_VAR_EXPORT jk_module; */
-AP_DECLARE_DATA module jk_module;
+AP_MODULE_DECLARE_DATA module jk_module;
 
-
 typedef struct {
 
     /*
@@ -326,7 +325,7 @@
             
             /* Debug - try to get around rwrite */
             while( ll > 0 ) {
-                long toSend=(ll>CHUNK_SIZE) ? CHUNK_SIZE : ll;
+                size_t toSend=(ll>CHUNK_SIZE) ? CHUNK_SIZE : ll;
                 r = ap_rwrite((const char *)bb, toSend, p->r );
                 jk_log(main_log, JK_LOG_DEBUG, 
                        "writing %ld (%ld) out of %ld \n",toSend, r, ll );
@@ -535,7 +534,7 @@
         }
 
         if(conf->envvars_in_use) {
-            apr_array_header_t *t = apr_table_elts(conf->envvars);
+            const apr_array_header_t *t = apr_table_elts(conf->envvars);
             if(t && t->nelts) {
                 int i;
                 apr_table_entry_t *elts = (apr_table_entry_t *)t->elts;
@@ -563,7 +562,7 @@
     s->num_headers      = 0;
     if(r->headers_in && apr_table_elts(r->headers_in)) {
         int need_content_length_header = (!s->is_chunked &&
s->content_length == 0) ? JK_TRUE : JK_FALSE;
-        apr_array_header_t *t = apr_table_elts(r->headers_in);
+        const apr_array_header_t *t = apr_table_elts(r->headers_in);
         if(t && t->nelts) {
             int i;
             apr_table_entry_t *elts = (apr_table_entry_t *)t->elts;
@@ -1514,7 +1513,7 @@
     return;
 }
 
-static void jk_post_config(apr_pool_t *pconf, 
+static int jk_post_config(apr_pool_t *pconf, 
                            apr_pool_t *plog, 
                            apr_pool_t *ptemp, 
                            server_rec *s)
@@ -1528,6 +1527,7 @@
             init_jk( pconf, conf, s );
         }
     }
+	return OK;
 }
 
 /** Use the internal mod_jk mappings to find if this is a request for

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: [PATCH] mod_jk for Apache 2.0 minor fixes

Posted by Justin Erenkrantz <je...@ebuilt.com>.
On Fri, Nov 30, 2001 at 07:25:40PM -0500, GAWLAS,JULIUS (HP-Cupertino,ex1) wrote:
> This patch contains minor fixes for mod_jk for Apache 2.0; 
> 
> Most important is the change in prototype of jk_post_config 
> which used to be void but now needs to return success code, 
> also changes to types of some variables to better confirm to 
> Apache 2.0 types.
> 
> Let me know if you have any comments.

FWIW, +1 (non-binding) from the httpd-2.0 peanut 
gallery.  =)  -- justin


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: JK versions

Posted by Remy Maucherat <re...@apache.org>.
> There is an important issue to discuss - labeling mod_jk.
>
> As you know, we are trying to make some improvements in jk, start using
> APR, etc. That will involve few significant changes - and some people
> may want to have a more 'stable' jk.
>
> There are 4 versions of jk:
>
> Let's call 1.0 what is present in tomcat3.2.x repository.
>
> Let's call 1.1 what is present in 3.3 repository. It is backward
> compatible with Jk1.0, has many fixes, etc.
>
> 1.2 - what is in jakarta-tomcat-connectors/jk, the same as 1.1 plus
> support for Apache2.0 ( Jk1.1 doesn't support apache2.0 since it wasn't
> available at that time ). This version also have support for tomcat4.0
> and initial code for ajp14.
>
> I would call '1.2' the version that was in CVS around Oct 15 ( i.e. after
> both 3.3 and 4.0.1 were released, before any refactoring was started ).
>
> So far all the changes in the main tree were small. However some biger
> changes are needed and are already in progress. We'll have a simpler build
> system, support for APR, lot more flexibility, simpler configuration.
>
> I would like to call the next version of jk 2.0, as a number of internal
> APIs will change.
>
> ( all those numbers are made up - we can call them 1, 2, 3, 4 instead
> of 1.0, 1.1, ... ).
>
> What I would like to do is make a branch for mod_jk 1.2, and eventually
> build a snapshot.
>
> Eventually we should start a release plan and have a vote on the
> names and such.
>
> Since names/labels/versions are allways fun thing to discuss, I'm
> open to any other naming scheme - but we need to have one, it's extremely
> confusing otherwise.
>
> I will not check anything else into mod_jk until this is decided (
> since my next commit is pretty big and likely to brake things,
> I did a lot of changes in uri_map, etc. - I need a stable
> branch labeled before doing the commit ).

+1. Tag it (or branch it) !

Remy


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: JK versions

Posted by Bojan Smojver <bo...@binarix.com>.
costinm@covalent.net wrote:

> What I would like to do is make a branch for mod_jk 1.2, and eventually
> build a snapshot.

If I'm getting this right, you are trying to preserve 1.2 for bug fixing
a backward compatibility, while focusing on 2.0. Yes?

If so, I'm [+1] for it as it seems very reasonable.

Bojan

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


JK versions

Posted by co...@covalent.net.
There is an important issue to discuss - labeling mod_jk.

As you know, we are trying to make some improvements in jk, start using
APR, etc. That will involve few significant changes - and some people
may want to have a more 'stable' jk.

There are 4 versions of jk:

Let's call 1.0 what is present in tomcat3.2.x repository.

Let's call 1.1 what is present in 3.3 repository. It is backward
compatible with Jk1.0, has many fixes, etc.

1.2 - what is in jakarta-tomcat-connectors/jk, the same as 1.1 plus
support for Apache2.0 ( Jk1.1 doesn't support apache2.0 since it wasn't
available at that time ). This version also have support for tomcat4.0
and initial code for ajp14.

I would call '1.2' the version that was in CVS around Oct 15 ( i.e. after
both 3.3 and 4.0.1 were released, before any refactoring was started ).

So far all the changes in the main tree were small. However some biger
changes are needed and are already in progress. We'll have a simpler build
system, support for APR, lot more flexibility, simpler configuration.

I would like to call the next version of jk 2.0, as a number of internal
APIs will change.

( all those numbers are made up - we can call them 1, 2, 3, 4 instead
of 1.0, 1.1, ... ).

What I would like to do is make a branch for mod_jk 1.2, and eventually
build a snapshot.

Eventually we should start a release plan and have a vote on the
names and such.

Since names/labels/versions are allways fun thing to discuss, I'm
open to any other naming scheme - but we need to have one, it's extremely
confusing otherwise.

I will not check anything else into mod_jk until this is decided (
since my next commit is pretty big and likely to brake things,
I did a lot of changes in uri_map, etc. - I need a stable
branch labeled before doing the commit ).

Costin



--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>