You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Ishan Chattopadhyaya (JIRA)" <ji...@apache.org> on 2017/03/21 16:25:42 UTC

[jira] [Commented] (SOLR-10304) Refactor Document/Stored-field handling out of SolrIndexSearcher

    [ https://issues.apache.org/jira/browse/SOLR-10304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15934831#comment-15934831 ] 

Ishan Chattopadhyaya commented on SOLR-10304:
---------------------------------------------

+1 to the refactoring! The SolrIndexSearcher looks much cleaner now.

bq. Renamed static DocsStreamer.getDoc(doc) to convertLuceneDocToSolrDoc. I considered moving it to SolrDocumentFetcher but it's not 100% clear it should. Maybe?
There's also RTGC.toSolrDoc(), RTGC.toSolrInputDocument() that are very similar to DocsStreamer.getDoc(). There maybe one or two more of these methods. I think those should all be co-located in some utility class.

> Refactor Document/Stored-field handling out of SolrIndexSearcher
> ----------------------------------------------------------------
>
>                 Key: SOLR-10304
>                 URL: https://issues.apache.org/jira/browse/SOLR-10304
>             Project: Solr
>          Issue Type: Task
>      Security Level: Public(Default Security Level. Issues are Public) 
>            Reporter: David Smiley
>            Assignee: David Smiley
>         Attachments: SOLR_10304_SolrDocumentFetcher.patch
>
>
> SolrIndexSearcher is nearly 3 thousand lines of code.  A sizable part of it pertains to Document handling, including various stored-field concerns and docValue substitutions (docValueAsStored related).  There are already comments marking the start and end of this part of SolrIndexSearcher, plus there some fields and their initialization that are only in support of those methods.  I propose that all of this go to a new companion class {{SolrDocumentFetcher}}. SolrIndexSearcher can add a getter for it, and where applicable existing callers can call to this instead.  "Override"'s will need to stay of course.
> ( Originally proposed in SOLR-10286 )



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org