You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@cocoon.apache.org by Stuart Roebuck <st...@adolos.co.uk> on 2001/08/14 13:39:45 UTC

[C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)

I wonder whether it would be worth considering renaming and/or clarifying 
the documentation of the modifiedSince() method defined in the Modifiable 
interface?  The uses of this method in Cocoon appear to fit with the 
description of the method as implemented in AbstractServerPage, however 
this definition is probably the exact opposite of what you would expect 
for a method of this name, and I'm not sure that it is in keeping with the 
description in Modifiable.java.

I would expect modifiedSince(date) to mean "has this object been modified 
since the given date, if it has return true".

But the implementation is "has this object been modified since the given 
date, if *not* return true".

Unfortunately, I can't think of a better name than: 
needsRefreshingGivenLastAffectingChangeDateOf(Date dateOfLastUpdate)  :-)

Stuart.

-------------------------------------------------------------------------
Stuart Roebuck                                  stuart.roebuck@adolos.com
Lead Developer                               Java, XML, MacOS X, XP, etc.
ADOLOS                                           <http://www.adolos.com/>

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Re: AW: [C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)

Posted by giacomo <gi...@apache.org>.
On Tue, 14 Aug 2001, Carsten Ziegeler wrote:

> > Stuart Roebuck wrote:
> >
> >
> > I wonder whether it would be worth considering renaming and/or clarifying
> > the documentation of the modifiedSince() method defined in the Modifiable
> > interface?  The uses of this method in Cocoon appear to fit with the
> > description of the method as implemented in AbstractServerPage, however
> > this definition is probably the exact opposite of what you would expect
> > for a method of this name, and I'm not sure that it is in keeping
> > with the
> > description in Modifiable.java.
> >
> > I would expect modifiedSince(date) to mean "has this object been modified
> > since the given date, if it has return true".
> >
> > But the implementation is "has this object been modified since the given
> > date, if *not* return true".
> >
> > Unfortunately, I can't think of a better name than:
> > needsRefreshingGivenLastAffectingChangeDateOf(Date dateOfLastUpdate)  :-)
> >
> Let me guess, you are a long time OpenStep (Cocoa, WebObjects) user? Right?
> If so, welcome. If not, you have managed half the way of learning it.

Berin has written Resource Monitoring Components for Excalibur which
should be integrated into Cocoon to have solved the problem of reloading
modified resources (ie. files). So I would sugest to leave it as is and
do the propper rework later on when it is available.

Giacomo

>
> Carsten
>
> > Stuart.
> >
> > -------------------------------------------------------------------------
> > Stuart Roebuck                                  stuart.roebuck@adolos.com
> > Lead Developer                               Java, XML, MacOS X, XP, etc.
> > ADOLOS                                           <http://www.adolos.com/>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> > For additional commands, email: cocoon-dev-help@xml.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


AW: [C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)

Posted by Carsten Ziegeler <cz...@sundn.de>.
> Stuart Roebuck wrote:
>
> On Tuesday, August 14, 2001, at 12:52  pm, Carsten Ziegeler wrote:
>
> >> Stuart Roebuck wrote:
> >>
> >> I wonder whether it would be worth considering renaming and/or
> clarifying
> >> the documentation of the modifiedSince() method defined in the
> Modifiable
> >> interface?  The uses of this method in Cocoon appear to fit with the
> >> description of the method as implemented in AbstractServerPage, however
> >> this definition is probably the exact opposite of what you would expect
> >> for a method of this name, and I'm not sure that it is in keeping
> >> with the
> >> description in Modifiable.java.
> >>
> >> I would expect modifiedSince(date) to mean "has this object
> been modified
> >> since the given date, if it has return true".
> >>
> >> But the implementation is "has this object been modified since
> the given
> >> date, if *not* return true".
> >>
> >> Unfortunately, I can't think of a better name than:
> >> needsRefreshingGivenLastAffectingChangeDateOf(Date
> dateOfLastUpdate)  :-
> >> )
> >>
> > Let me guess, you are a long time OpenStep (Cocoa, WebObjects) user?
> > Right?
> > If so, welcome. If not, you have managed half the way of learning it.
> >
> > Carsten
>
> I'm afraid you've completely lost me here.  I've never used OpenStep or
> WebObjects, though I have played with Cocoa a little.  Is this a joke
> about long method names?
>
Oh, what a pitty. Yes, it is. The method names of the OpenStep API (the
previous version of Cocoa) are very verbose and there often lengthy
which resulting in various contests where you searched the official
docs for the longest method name. I don't remember the exact class or
name, but there exists a rarely used method which name might be more
than 120 characters long!
The advantage of this method naming scheme is that it is so convenient
you can simply guess a method name without looking up the docs. Yeah,
that was a great time, unfortunately this is not possible with Java.
Ok, enough advertising. And please I don't want to start a thread about
method naming.

Putting it short: I like such methods names as they are very clear,
you don't have to read the docs! And I hoped to found another WO expert.

Carsten

> Stuart.
>
>
> -------------------------------------------------------------------------
> Stuart Roebuck                                  stuart.roebuck@adolos.com
> Lead Developer                               Java, XML, MacOS X, XP, etc.
> ADOLOS                                           <http://www.adolos.com/>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Re: AW: [C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)

Posted by Stuart Roebuck <st...@adolos.co.uk>.
On Tuesday, August 14, 2001, at 12:52  pm, Carsten Ziegeler wrote:

>> Stuart Roebuck wrote:
>>
>> I wonder whether it would be worth considering renaming and/or clarifying
>> the documentation of the modifiedSince() method defined in the Modifiable
>> interface?  The uses of this method in Cocoon appear to fit with the
>> description of the method as implemented in AbstractServerPage, however
>> this definition is probably the exact opposite of what you would expect
>> for a method of this name, and I'm not sure that it is in keeping
>> with the
>> description in Modifiable.java.
>>
>> I would expect modifiedSince(date) to mean "has this object been modified
>> since the given date, if it has return true".
>>
>> But the implementation is "has this object been modified since the given
>> date, if *not* return true".
>>
>> Unfortunately, I can't think of a better name than:
>> needsRefreshingGivenLastAffectingChangeDateOf(Date dateOfLastUpdate)  :-
>> )
>>
> Let me guess, you are a long time OpenStep (Cocoa, WebObjects) user? 
> Right?
> If so, welcome. If not, you have managed half the way of learning it.
>
> Carsten

I'm afraid you've completely lost me here.  I've never used OpenStep or 
WebObjects, though I have played with Cocoa a little.  Is this a joke 
about long method names?

Stuart.


-------------------------------------------------------------------------
Stuart Roebuck                                  stuart.roebuck@adolos.com
Lead Developer                               Java, XML, MacOS X, XP, etc.
ADOLOS                                           <http://www.adolos.com/>

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


AW: [C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)

Posted by Carsten Ziegeler <cz...@sundn.de>.
> Stuart Roebuck wrote:
>
>
> I wonder whether it would be worth considering renaming and/or clarifying
> the documentation of the modifiedSince() method defined in the Modifiable
> interface?  The uses of this method in Cocoon appear to fit with the
> description of the method as implemented in AbstractServerPage, however
> this definition is probably the exact opposite of what you would expect
> for a method of this name, and I'm not sure that it is in keeping
> with the
> description in Modifiable.java.
>
> I would expect modifiedSince(date) to mean "has this object been modified
> since the given date, if it has return true".
>
> But the implementation is "has this object been modified since the given
> date, if *not* return true".
>
> Unfortunately, I can't think of a better name than:
> needsRefreshingGivenLastAffectingChangeDateOf(Date dateOfLastUpdate)  :-)
>
Let me guess, you are a long time OpenStep (Cocoa, WebObjects) user? Right?
If so, welcome. If not, you have managed half the way of learning it.

Carsten

> Stuart.
>
> -------------------------------------------------------------------------
> Stuart Roebuck                                  stuart.roebuck@adolos.com
> Lead Developer                               Java, XML, MacOS X, XP, etc.
> ADOLOS                                           <http://www.adolos.com/>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org