You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Zhe Zhang (JIRA)" <ji...@apache.org> on 2015/04/26 07:21:38 UTC
[jira] [Created] (HDFS-8255) Rename getBlockReplication to
getPreferredBlockStorageNum
Zhe Zhang created HDFS-8255:
-------------------------------
Summary: Rename getBlockReplication to getPreferredBlockStorageNum
Key: HDFS-8255
URL: https://issues.apache.org/jira/browse/HDFS-8255
Project: Hadoop HDFS
Issue Type: Improvement
Reporter: Zhe Zhang
Assignee: Zhe Zhang
We should rename {{BlockCollection#getBlockReplication}} to {{getPreferredBlockStorageNum}} for 2 reasons:
# Currently, this method actually returns the _preferred_ block replication factor instead of the _actual_ number of replicas. The current name is a little ambiguous.
# With the erasure coding feature, the name doesn't apply to striped blocks.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)