You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Eli Collins (JIRA)" <ji...@apache.org> on 2011/08/11 19:34:27 UTC

[jira] [Updated] (HADOOP-6896) Remove the Util separation in FileContext

     [ https://issues.apache.org/jira/browse/HADOOP-6896?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Eli Collins updated HADOOP-6896:
--------------------------------

    Labels: newbie  (was: )

> Remove the Util separation in FileContext
> -----------------------------------------
>
>                 Key: HADOOP-6896
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6896
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>            Reporter: Owen O'Malley
>            Assignee: Sanjay Radia
>              Labels: newbie
>
> I think from a usability point of view, it would be nicer to write:
> {code}
> fc.exist(path);
> {code}
> instead of:
> {code}
> fc.utils().exist(path);
> {code}
> We should use the javadoc to mark the fact that the util functions are not atomic.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira