You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "wangzhihui (Jira)" <ji...@apache.org> on 2024/04/10 08:53:00 UTC
[jira] [Commented] (HADOOP-19109) Fix metrics description
[ https://issues.apache.org/jira/browse/HADOOP-19109?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17835651#comment-17835651 ]
wangzhihui commented on HADOOP-19109:
-------------------------------------
[~wuxiaobao] Please add the code paragraphs to prove the true semantics of the metrics.
> Fix metrics description
> -----------------------
>
> Key: HADOOP-19109
> URL: https://issues.apache.org/jira/browse/HADOOP-19109
> Project: Hadoop Common
> Issue Type: Improvement
> Affects Versions: 3.3.0, 3.3.4
> Reporter: Xiaobao Wu
> Priority: Minor
> Labels: pull-request-available
>
> This description of the RpcLockWaitTimeNumOps metrics seems to be incorrect:
> {code:java}
> | `RpcQueueTimeNumOps` | Total number of RPC calls |
> | `RpcQueueTimeAvgTime` | Average queue time in milliseconds |
> | `RpcLockWaitTimeNumOps` | Total number of RPC calls (same as RpcQueueTimeNumOps) |{code}
> I think the description of this metrics should be more clear:
> {code:java}
> | `RpcLockWaitTimeNumOps` | Total number of waiting for lock acquisition |{code}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org