You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Xu Hao (Jira)" <ji...@apache.org> on 2024/09/20 14:57:00 UTC

[jira] [Created] (FLINK-36342) Rename misleading variable names

Xu Hao created FLINK-36342:
------------------------------

             Summary: Rename misleading variable names
                 Key: FLINK-36342
                 URL: https://issues.apache.org/jira/browse/FLINK-36342
             Project: Flink
          Issue Type: Improvement
          Components: Runtime / Checkpointing
            Reporter: Xu Hao


The variable named targetTotalBufferSize appears in class BufferDebloatConfiguration and some other classes has been incorrectly named. Based on the context and the origin of this variable, it is clearly a *Duration* type variable that is read from configuration(the key is
*taskmanager.network.memory.buffer-debloat.target* and default value is 1s). So a more suitable name might be targetTotalTime.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)