You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Niall Pemberton (JIRA)" <ji...@apache.org> on 2007/10/21 21:03:50 UTC

[jira] Created: (JCI-55) Improve FilesystemAlterationObserver implementation

Improve FilesystemAlterationObserver implementation
---------------------------------------------------

                 Key: JCI-55
                 URL: https://issues.apache.org/jira/browse/JCI-55
             Project: Commons JCI
          Issue Type: Improvement
          Components: fam
    Affects Versions: 1.0
            Reporter: Niall Pemberton


Proposal to factor back into fam's FilesystemAlterationObserverImpl the improvements proposed in IO-132:

1) Use a matching array technique to compare previous and current directory contents which minimizes object creation
2) Allow FileFilters to be specified to monitor only portions of the file system, ignoring files/directories of no interest. This is more efficient and reduces the amount of noise from un-wanted file/directory events
3) Add an option to make the observer case-insenstive for file names


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (JCI-55) Improve FilesystemAlterationObserver implementation

Posted by "Niall Pemberton (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCI-55?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Niall Pemberton updated JCI-55:
-------------------------------

    Attachment: FilesystemAlterationObserverImplTestCase.java
                commons-jci-fam-ObserverImpl-improvements.patch

If this patch is accepted then it has implications for the current FilesystemAlterationMonitor - since a single FilesystemAlterationObserver per root directory being observed no longer makes sense with the ability to filter.

Additionally in the IO-132 proposal I split out the basic FilesystemAlterationObserver plumbing (i.e. adding, removing and notifying listeners) into a separate abstract class leaving just the implementation of the checkAndNotify() method in FilesystemAlterationObserverImpl. This facilitates other  FilesystemAlterationObserver implementations and makes the FilesystemAlterationObserverImpl easier to read - although the current FilesystemAlterationMonitor is hardcoded only to the FilesystemAlterationObserverImpl.

> Improve FilesystemAlterationObserver implementation
> ---------------------------------------------------
>
>                 Key: JCI-55
>                 URL: https://issues.apache.org/jira/browse/JCI-55
>             Project: Commons JCI
>          Issue Type: Improvement
>          Components: fam
>    Affects Versions: 1.0
>            Reporter: Niall Pemberton
>         Attachments: commons-jci-fam-ObserverImpl-improvements.patch, FilesystemAlterationObserverImplTestCase.java
>
>
> Proposal to factor back into fam's FilesystemAlterationObserverImpl the improvements proposed in IO-132:
> 1) Use a matching array technique to compare previous and current directory contents which minimizes object creation
> 2) Allow FileFilters to be specified to monitor only portions of the file system, ignoring files/directories of no interest. This is more efficient and reduces the amount of noise from un-wanted file/directory events
> 3) Add an option to make the observer case-insenstive for file names

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.