You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@solr.apache.org by "Eric Pugh (Jira)" <ji...@apache.org> on 2026/02/07 13:07:00 UTC

[jira] [Commented] (SOLR-18109) Fix deprecated SolrPluginUtils.doStandardDebug

    [ https://issues.apache.org/jira/browse/SOLR-18109?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18057049#comment-18057049 ] 

Eric Pugh commented on SOLR-18109:
----------------------------------

I think also moving 
public static void doStandardResultsDebug.
 
Looking in commit comments, I think David want'ed the method doSimpleQuery to also move to DebugComponent.

> Fix deprecated SolrPluginUtils.doStandardDebug
> ----------------------------------------------
>
>                 Key: SOLR-18109
>                 URL: https://issues.apache.org/jira/browse/SOLR-18109
>             Project: Solr
>          Issue Type: Sub-task
>            Reporter: Eric Pugh
>            Priority: Major
>
> Looking at code and comments, this needs to be moved to debugcomponent, and then a comment in MoreLikeThis could be rmeoved!
>  
> // TODO resolve duplicated code with DebugComponent. Perhaps it should be added to
> // doStandardDebug?



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@solr.apache.org
For additional commands, e-mail: issues-help@solr.apache.org