You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@labs.apache.org by fi...@apache.org on 2007/11/03 03:04:25 UTC

svn commit: r591536 - in /labs/webarch/trunk/http/draft-fielding-http: p3-payload.html p3-payload.xml

Author: fielding
Date: Fri Nov  2 19:04:25 2007
New Revision: 591536

URL: http://svn.apache.org/viewvc?rev=591536&view=rev
Log:
Resolve [LABS-16]: [i14] Clarification regarding quoting of charset values

Modified:
    labs/webarch/trunk/http/draft-fielding-http/p3-payload.html
    labs/webarch/trunk/http/draft-fielding-http/p3-payload.xml

Modified: labs/webarch/trunk/http/draft-fielding-http/p3-payload.html
URL: http://svn.apache.org/viewvc/labs/webarch/trunk/http/draft-fielding-http/p3-payload.html?rev=591536&r1=591535&r2=591536&view=diff
==============================================================================
--- labs/webarch/trunk/http/draft-fielding-http/p3-payload.html (original)
+++ labs/webarch/trunk/http/draft-fielding-http/p3-payload.html Fri Nov  2 19:04:25 2007
@@ -552,7 +552,11 @@
 </pre><p id="rfc.section.2.1.p.6">Although HTTP allows an arbitrary token to be used as a charset value, any token that has a predefined value within the IANA
          Character Set registry <a href="#RFC1700" id="rfc.xref.RFC1700.2"><cite title="Assigned Numbers">[6]</cite></a>  <em class="bcp14">MUST</em> represent the character set defined by that registry. Applications <em class="bcp14">SHOULD</em> limit their use of character sets to those defined by the IANA registry.
       </p>
-      <p id="rfc.section.2.1.p.7">Implementors should be aware of IETF character set requirements <a href="#RFC2279" id="rfc.xref.RFC2279.1"><cite title="UTF-8, a transformation format of ISO 10646">[14]</cite></a>  <a href="#RFC2277" id="rfc.xref.RFC2277.1"><cite title="IETF Policy on Character Sets and Languages">[16]</cite></a>.
+      <p id="rfc.section.2.1.p.7">HTTP uses charset in two contexts: within an Accept-Charset request header (in which the charset value is an unquoted token)
+         and as the value of a parameter in a Content-type header (within a request or response), in which case the parameter value
+         of the charset parameter may be quoted.
+      </p>
+      <p id="rfc.section.2.1.p.8">Implementors should be aware of IETF character set requirements <a href="#RFC2279" id="rfc.xref.RFC2279.1"><cite title="UTF-8, a transformation format of ISO 10646">[14]</cite></a>  <a href="#RFC2277" id="rfc.xref.RFC2277.1"><cite title="IETF Policy on Character Sets and Languages">[16]</cite></a>.
       </p>
       <h3 id="rfc.section.2.1.1"><a href="#rfc.section.2.1.1">2.1.1</a>&nbsp;<a id="missing.charset" href="#missing.charset">Missing Charset</a></h3>
       <p id="rfc.section.2.1.1.p.1">Some HTTP/1.0 software has interpreted a Content-Type header without charset parameter incorrectly to mean "recipient should

Modified: labs/webarch/trunk/http/draft-fielding-http/p3-payload.xml
URL: http://svn.apache.org/viewvc/labs/webarch/trunk/http/draft-fielding-http/p3-payload.xml?rev=591536&r1=591535&r2=591536&view=diff
==============================================================================
--- labs/webarch/trunk/http/draft-fielding-http/p3-payload.xml (original)
+++ labs/webarch/trunk/http/draft-fielding-http/p3-payload.xml Fri Nov  2 19:04:25 2007
@@ -206,6 +206,13 @@
    sets to those defined by the IANA registry.
 </t>
 <t>
+   HTTP uses charset in two contexts: within an Accept-Charset request
+   header (in which the charset value is an unquoted token) and as the
+   value of a parameter in a Content-type header (within a request or
+   response), in which case the parameter value of the charset parameter
+   may be quoted.
+</t>
+<t>
    Implementors should be aware of IETF character set requirements <xref target="RFC2279"/>
    <xref target="RFC2277"/>.
 </t>



---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@labs.apache.org
For additional commands, e-mail: commits-help@labs.apache.org