You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@myfaces.apache.org by Andrew Robinson <an...@gmail.com> on 2007/08/30 17:49:48 UTC

[Trinidad] move RequestContextImpl._findRelativeComponent to public utility class

The method:

static private UIComponent _findRelativeComponent(
    UIComponent from,
    String      relativeId)

on RequestContextImpl is a very handy method, any objections to making
a JIRA issue to move this to a public class with static methods?

Maybe a public static on RenderingContext? Or is there a better class?

-Andrew

Re: [Trinidad] move RequestContextImpl._findRelativeComponent to public utility class

Posted by Adam Winer <aw...@gmail.com>.
On 9/4/07, Andrew Robinson <an...@gmail.com> wrote:
> I say that there was such a method in the RenderUtils. The method
> there does not support the "::" syntax.

It should...

> The function is not rendering
> specific, it can be used during even broadcasting, decoding and other
> phases as well. That is why I felt that it should be on
> ComponentUtils, since it is a method to help with finding components.

Sure, ComponentUtils works fine.

-- Adam

>
> On 9/3/07, Adam Winer <aw...@gmail.com> wrote:
> > I'd add it to RenderUtils, which already has a getRelativeId()
> > API.
> >
> > -- Adam
> >
> >
> > On 8/30/07, Andrew Robinson <an...@gmail.com> wrote:
> > > The method:
> > >
> > > static private UIComponent _findRelativeComponent(
> > >     UIComponent from,
> > >     String      relativeId)
> > >
> > > on RequestContextImpl is a very handy method, any objections to making
> > > a JIRA issue to move this to a public class with static methods?
> > >
> > > Maybe a public static on RenderingContext? Or is there a better class?
> > >
> > > -Andrew
> > >
> >
>

Re: [Trinidad] move RequestContextImpl._findRelativeComponent to public utility class

Posted by Andrew Robinson <an...@gmail.com>.
I say that there was such a method in the RenderUtils. The method
there does not support the "::" syntax. The function is not rendering
specific, it can be used during even broadcasting, decoding and other
phases as well. That is why I felt that it should be on
ComponentUtils, since it is a method to help with finding components.

On 9/3/07, Adam Winer <aw...@gmail.com> wrote:
> I'd add it to RenderUtils, which already has a getRelativeId()
> API.
>
> -- Adam
>
>
> On 8/30/07, Andrew Robinson <an...@gmail.com> wrote:
> > The method:
> >
> > static private UIComponent _findRelativeComponent(
> >     UIComponent from,
> >     String      relativeId)
> >
> > on RequestContextImpl is a very handy method, any objections to making
> > a JIRA issue to move this to a public class with static methods?
> >
> > Maybe a public static on RenderingContext? Or is there a better class?
> >
> > -Andrew
> >
>

Re: [Trinidad] move RequestContextImpl._findRelativeComponent to public utility class

Posted by Adam Winer <aw...@gmail.com>.
I'd add it to RenderUtils, which already has a getRelativeId()
API.

-- Adam


On 8/30/07, Andrew Robinson <an...@gmail.com> wrote:
> The method:
>
> static private UIComponent _findRelativeComponent(
>     UIComponent from,
>     String      relativeId)
>
> on RequestContextImpl is a very handy method, any objections to making
> a JIRA issue to move this to a public class with static methods?
>
> Maybe a public static on RenderingContext? Or is there a better class?
>
> -Andrew
>