You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Andrew Ash (JIRA)" <ji...@apache.org> on 2014/09/15 10:14:33 UTC

[jira] [Created] (SPARK-3528) Reading data from file:/// should be called NODE_LOCAL not PROCESS_LOCAL

Andrew Ash created SPARK-3528:
---------------------------------

             Summary: Reading data from file:/// should be called NODE_LOCAL not PROCESS_LOCAL
                 Key: SPARK-3528
                 URL: https://issues.apache.org/jira/browse/SPARK-3528
             Project: Spark
          Issue Type: Bug
          Components: Spark Core
    Affects Versions: 1.1.0
            Reporter: Andrew Ash


Note that reading from {{file:///.../pom.xml}} is called a PROCESS_LOCAL task

{noformat}
14/09/15 00:59:13 INFO TaskSetManager: Starting task 0.0 in stage 0.0 (TID 0, localhost, PROCESS_LOCAL, 1191 bytes)
14/09/15 00:59:13 INFO TaskSetManager: Starting task 1.0 in stage 0.0 (TID 1, localhost, PROCESS_LOCAL, 1191 bytes)
14/09/15 00:59:13 INFO Executor: Running task 0.0 in stage 0.0 (TID 0)
14/09/15 00:59:13 INFO Executor: Running task 1.0 in stage 0.0 (TID 1)
14/09/15 00:59:13 INFO HadoopRDD: Input split: file:/Users/aash/git/spark/pom.xml:20862+20863
14/09/15 00:59:13 INFO HadoopRDD: Input split: file:/Users/aash/git/spark/pom.xml:0+20862
{noformat}

There is an outstanding TODO in {{HadoopRDD.scala}} that may be related:

{noformat}
  override def getPreferredLocations(split: Partition): Seq[String] = {
    // TODO: Filtering out "localhost" in case of file:// URLs
    val hadoopSplit = split.asInstanceOf[HadoopPartition]
    hadoopSplit.inputSplit.value.getLocations.filter(_ != "localhost")
  }
{noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org