You are viewing a plain text version of this content. The canonical link for it is here.
Posted to log4j-dev@logging.apache.org by rg...@apache.org on 2010/05/31 22:16:02 UTC

svn commit: r949854 - /logging/log4j/branches/BRANCH_2_0_EXPERIMENTAL/rgoers/log4j2-api/src/main/java/org/apache/logging/log4j/Level.java

Author: rgoers
Date: Mon May 31 20:16:01 2010
New Revision: 949854

URL: http://svn.apache.org/viewvc?rev=949854&view=rev
Log:
Add @doubt comments

Modified:
    logging/log4j/branches/BRANCH_2_0_EXPERIMENTAL/rgoers/log4j2-api/src/main/java/org/apache/logging/log4j/Level.java

Modified: logging/log4j/branches/BRANCH_2_0_EXPERIMENTAL/rgoers/log4j2-api/src/main/java/org/apache/logging/log4j/Level.java
URL: http://svn.apache.org/viewvc/logging/log4j/branches/BRANCH_2_0_EXPERIMENTAL/rgoers/log4j2-api/src/main/java/org/apache/logging/log4j/Level.java?rev=949854&r1=949853&r2=949854&view=diff
==============================================================================
--- logging/log4j/branches/BRANCH_2_0_EXPERIMENTAL/rgoers/log4j2-api/src/main/java/org/apache/logging/log4j/Level.java (original)
+++ logging/log4j/branches/BRANCH_2_0_EXPERIMENTAL/rgoers/log4j2-api/src/main/java/org/apache/logging/log4j/Level.java Mon May 31 20:16:01 2010
@@ -40,6 +40,10 @@ package org.apache.logging.log4j;
  * or different logging API's (for example, the same level could be FINER with one converter and TRACE
  * with another. (RG) It's an Enum. All enums must provide the valueOf method. toLevel(String) is carried
  * over from 1.x.
+ *
+ * @doubt Curt makes valid points. I like this being an enum but I dislike that it doesn't support ALERT, SEVERE,
+ * NOTICE, SERIOUS, EMERGENCY, etc. Do we just add them? That multiples the number of methods in the Logger
+ * interface. I've heard suggestions that the log methods should be added to the Level. That would make sense.
  */
 public enum Level {
     OFF(0), FATAL(1), ERROR(2), WARN(3), INFO(4), DEBUG(5), TRACE(6), ALL(Integer.MAX_VALUE);
@@ -75,6 +79,10 @@ public enum Level {
     }
 
     /**
+     * @doubt I really dislike the "greaterOrEqual" and "lessOrEqual" methods. I can never remember whether
+     * the test compares this level to the passed in level or the other way around. As it stands, this
+     * method is not intuitive as the name is greaterOrEqual but the test it does is <=.
+     *
      * Compares the specified Level against this one.
      * @param level The level to check.
      * @return True if the passed Level is more general or the same as this Level.



---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org