You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "David Smiley (Created) (JIRA)" <ji...@apache.org> on 2012/04/03 23:52:27 UTC

[jira] [Created] (SOLR-3313) Rename "Query Type" to "Request Handler" in API and UI

Rename "Query Type" to "Request Handler" in API and UI 
-------------------------------------------------------

                 Key: SOLR-3313
                 URL: https://issues.apache.org/jira/browse/SOLR-3313
             Project: Solr
          Issue Type: Improvement
            Reporter: David Smiley
             Fix For: 4.0


Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.

As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()



--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (SOLR-3313) Rename "Query Type" to "Request Handler" in API and UI

Posted by "Stefan Matheis (steffkes) (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stefan Matheis (steffkes) updated SOLR-3313:
--------------------------------------------

    Component/s: web gui
    
> Rename "Query Type" to "Request Handler" in API and UI 
> -------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: web gui
>            Reporter: David Smiley
>             Fix For: 4.0
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Commented] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "David Smiley (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13393591#comment-13393591 ] 

David Smiley commented on SOLR-3313:
------------------------------------

I'm seeing numerous usages of "query type" as a reference to the query parser too :-(   Ugh.  I'll clean those up to be "query parser" or similar based on context.  An example in QParser.getParser()  (my emphasis added with bold):

BEFORE:{quote}
  Create a <code>QParser</code> to parse <code>qstr</code>,
  assuming that the default *query type* is <code>*defaultType*</code>.
  The *query type* may be overridden by local parameters in the query
  string itself.  For example if *defaultType*=<code>"dismax"</code>
  and qstr=<code>foo</code>, then the dismax query parser will be used
  to parse and construct the query object.  However
  if qstr=<code>\{!prefix f=myfield}foo</code>
  then the prefix query parser will be used.

  public static QParser getParser(String qstr, String *defaultType*, SolrQueryRequest req) throws ParseException
{quote}
AFTER: {quote}
  Create a <code>QParser</code> to parse <code>qstr</code>,
  assuming that the default *query parser* is <code>*defaultParser*</code>.
  The *query parser* may be overridden by local parameters in the query
  string itself.  For example if *defaultParser*=<code>"dismax"</code>
  and qstr=<code>foo</code>, then the dismax query parser will be used
  to parse and construct the query object.  However
  if qstr=<code>\{!prefix f=myfield}foo</code>
  then the prefix query parser will be used.

  public static QParser getParser(String qstr, String *defaultParser*, SolrQueryRequest req) throws ParseException
{quote}
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "David Smiley (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Smiley updated SOLR-3313:
-------------------------------

    Attachment: SOLR-3313_Rename_Query_Type_to_Request_Handler.patch

Attached is a patch focusing on the renames where the Request Handler was intended.  I will use a separate patch for cases where the query parser was intended.
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>         Attachments: SOLR-3313_Rename_Query_Type_to_Request_Handler.patch
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Resolved] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "David Smiley (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Smiley resolved SOLR-3313.
--------------------------------

    Resolution: Fixed

Committed to trunk in r1352760 and 4x in r1352761.  Closing.
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>         Attachments: SOLR-3313_Rename_Query_Type_to_Query_Parser.patch, SOLR-3313_Rename_Query_Type_to_Request_Handler.patch
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Commented] (SOLR-3313) Rename "Query Type" to "Request Handler" in API and UI

Posted by "Yonik Seeley (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13245846#comment-13245846 ] 

Yonik Seeley commented on SOLR-3313:
------------------------------------

Yeah, that makes sense.
                
> Rename "Query Type" to "Request Handler" in API and UI 
> -------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: David Smiley
>             Fix For: 4.0
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "David Smiley (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Smiley updated SOLR-3313:
-------------------------------

    Attachment: SOLR-3313_Rename_Query_Type_to_Query_Parser.patch

And attached are renames related to "query type" being a reference to the parser.

I made some wiki changes here and there too, at least to some of the more current wiki pages.
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>         Attachments: SOLR-3313_Rename_Query_Type_to_Query_Parser.patch, SOLR-3313_Rename_Query_Type_to_Request_Handler.patch
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Updated] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "Hoss Man (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hoss Man updated SOLR-3313:
---------------------------

    Component/s:     (was: web gui)
                 clients - java
        Summary: Rename "Query Type" to "Request Handler" in SolrJ APIs  (was: Rename "Query Type" to "Request Handler" in API and UI )

The Admin UI was already updated to reflect this in another issue, so clarifying scope of summary to be specific about SolrJ.

                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>             Fix For: 4.0
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Assigned] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "David Smiley (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Smiley reassigned SOLR-3313:
----------------------------------

    Assignee: David Smiley
    
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] [Commented] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs

Posted by "David Smiley (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13397259#comment-13397259 ] 

David Smiley commented on SOLR-3313:
------------------------------------

I committed SOLR-3313_Rename_Query_Type_to_Request_Handler.patch to trunk r1351932 and to 4x r1351933. 
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>         Attachments: SOLR-3313_Rename_Query_Type_to_Request_Handler.patch
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand we want to retain the "qt" parameter as such but I think we should change the names of it wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org