You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Ufuk Celebi (JIRA)" <ji...@apache.org> on 2014/06/25 15:57:26 UTC

[jira] [Resolved] (FLINK-760) Introduce a DataSet.distinct() operator

     [ https://issues.apache.org/jira/browse/FLINK-760?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ufuk Celebi resolved FLINK-760.
-------------------------------

    Resolution: Fixed

Fixed in e2aabd90604d5880ef8e7b82ce58de218ddd48a7.

> Introduce a DataSet.distinct() operator
> ---------------------------------------
>
>                 Key: FLINK-760
>                 URL: https://issues.apache.org/jira/browse/FLINK-760
>             Project: Flink
>          Issue Type: Improvement
>            Reporter: GitHub Import
>              Labels: github-import
>             Fix For: pre-apache
>
>
> I think it would be more readable and user-friendly to have a DataSet.distinct() operator instead of manually use e.g. for Tuple5:
> ```java
> DataSet.groupBy(0,1,2,3,4).reduceGroup(new GroupReduceFunction<...>() {
> 	private static final long serialVersionUID = 1L;
> 	@Override
> 	public void reduce(Iterator<...> values, Collector<...> out) throws Exception {
> 		out.collect(values.next());						
> 	}					
> });
> ```
> ---------------- Imported from GitHub ----------------
> Url: https://github.com/stratosphere/stratosphere/issues/760
> Created by: [twalthr|https://github.com/twalthr]
> Labels: enhancement, java api, 
> Milestone: Release 0.6 (unplanned)
> Created at: Tue May 06 11:28:02 CEST 2014
> State: open



--
This message was sent by Atlassian JIRA
(v6.2#6252)