You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Hadoop QA (Jira)" <ji...@apache.org> on 2020/04/11 18:23:00 UTC
[jira] [Commented] (HDFS-7550) Minor followon cleanups from
HDFS-7543
[ https://issues.apache.org/jira/browse/HDFS-7550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17081511#comment-17081511 ]
Hadoop QA commented on HDFS-7550:
---------------------------------
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue} 0m 0s{color} | {color:blue} Docker mode activated. {color} |
| {color:red}-1{color} | {color:red} patch {color} | {color:red} 0m 6s{color} | {color:red} HDFS-7550 does not apply to trunk. Rebase required? Wrong Branch? See https://wiki.apache.org/hadoop/HowToContribute for help. {color} |
\\
\\
|| Subsystem || Report/Notes ||
| JIRA Issue | HDFS-7550 |
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12688409/HDFS-7550.001.patch |
| Console output | https://builds.apache.org/job/PreCommit-HDFS-Build/29143/console |
| Powered by | Apache Yetus 0.8.0 http://yetus.apache.org |
This message was automatically generated.
> Minor followon cleanups from HDFS-7543
> --------------------------------------
>
> Key: HDFS-7550
> URL: https://issues.apache.org/jira/browse/HDFS-7550
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: namenode
> Affects Versions: 2.7.0
> Reporter: Charles Lamb
> Priority: Minor
> Attachments: HDFS-7550.001.patch
>
>
> The commit of HDFS-7543 crossed paths with these comments:
> FSDirMkdirOp.java
> in #mkdirs, you removed the final String srcArg = src. This should be left in. Many IDEs will whine about making assignments to formal args and that's why it was put in in the first place.
> FSDirRenameOp.java
> #renameToInt, dstIIP (and resultingStat) could benefit from final's.
> FSDirXAttrOp.java
> I'm not sure why you've moved the call to getINodesInPath4Write and checkXAttrChangeAccess inside the writeLock.
> FSDirStatAndListing.java
> The javadoc for the @param src needs to be changed to reflect that it's an INodesInPath, not a String. Nit: it might be better to rename the INodesInPath arg from src to iip.
> #getFileInfo4DotSnapshot is now unused since you in-lined it into #getFileInfo.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org