You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Arun Suresh (JIRA)" <ji...@apache.org> on 2016/07/06 04:27:11 UTC

[jira] [Comment Edited] (YARN-5216) Expose configurable preemption policy for OPPORTUNISTIC containers running on the NM

    [ https://issues.apache.org/jira/browse/YARN-5216?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15363748#comment-15363748 ] 

Arun Suresh edited comment on YARN-5216 at 7/6/16 4:26 AM:
-----------------------------------------------------------

Thanks for the patch [~hrsharma] and apologize for the delay.

Some initial comments:
# I feel we should rename the {{OpportunisticContainerManager}} to {{PreemptingContainerManager}}
# The {{queuedGuaranteedContainers}} should also be pulled into the {{OpportunisticContainerManagerImpl}}
# You should use the java [ServiceLoader|http://docs.oracle.com/javase/8/docs/api/java/util/ServiceLoader.html] framework to plug in implementations of interfaces rather than using reflection utils. You can see how hadoop {{KeyProvider}} is created for reference.

[~kkaranasos], do take a look at the patch since you should be most familiar with it.



was (Author: asuresh):
Thanks for the patch [~hrsharma] and apologize for the delay.

Some initial comments:
# I feel we should rename the {{OpportunisticContainerManager}} to {{PreemptingContainerManager}}
# The {{queuedGuaranteedContainers}} should also be pulled into the {{OpportunisticContainerManagerImpl}}
# You should use the java [ServiceLoader|http://docs.oracle.com/javase/8/docs/api/java/util/ServiceLoader.html] framework plug in implementations of interfaces. You can see how hadoop {{KeyProvider}} is created for reference.

[~kkaranasos], do take a look at the patch since you should be most familiar with it.


> Expose configurable preemption policy for OPPORTUNISTIC containers running on the NM
> ------------------------------------------------------------------------------------
>
>                 Key: YARN-5216
>                 URL: https://issues.apache.org/jira/browse/YARN-5216
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Arun Suresh
>            Assignee: Hitesh Sharma
>         Attachments: YARN5216.001.patch, yarn5216.002.patch
>
>
> Currently, the default action taken by the QueuingContainerManager, introduced in YARN-2883, when a GUARANTEED Container is scheduled on an NM with OPPORTUNISTIC containers using up resources, is to KILL the running OPPORTUNISTIC containers.
> This JIRA proposes to expose a configurable hook to allow the NM to take a different action.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org