You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@thrift.apache.org by "David Reiss (JIRA)" <ji...@apache.org> on 2009/04/15 23:24:15 UTC
[jira] Commented: (THRIFT-409) Add "union" to Thrift
[ https://issues.apache.org/jira/browse/THRIFT-409?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12699393#action_12699393 ]
David Reiss commented on THRIFT-409:
------------------------------------
I think this should probably be done with less code duplication. Specifically:
- In the parser, make it accept struct or union as the beginning of the definition, rather than creating a whole separate rule for unions.
- Rather than "add_union" in programs and "generate_union" in generators, just make unions a special structure with a flag (or annotation!) set. That way all languages will have instant interoperability with unions (with a little help from the application).
> Add "union" to Thrift
> ---------------------
>
> Key: THRIFT-409
> URL: https://issues.apache.org/jira/browse/THRIFT-409
> Project: Thrift
> Issue Type: New Feature
> Reporter: Bryan Duxbury
> Assignee: Bryan Duxbury
> Fix For: 0.2
>
> Attachments: thrift-409.patch
>
>
> It would be very helpful to have a "union" construct in Thrift. Let's decide on the design and then break up into sub-issues to add this feature.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.