You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues-all@impala.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2018/11/23 19:43:00 UTC

[jira] [Commented] (IMPALA-7839) Refactor Catalog::toCatalogObjectKey and CatalogObject::getUniqueName to reduce code repetition

    [ https://issues.apache.org/jira/browse/IMPALA-7839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16697470#comment-16697470 ] 

ASF subversion and git services commented on IMPALA-7839:
---------------------------------------------------------

Commit 8c59f0dcef11389ebfde1788aa3237b7b31ab3a4 in impala's branch refs/heads/master from [~fredyw]
[ https://git-wip-us.apache.org/repos/asf?p=impala.git;h=8c59f0d ]

IMPALA-7839: Remove code duplication for getting a unique catalog object name

This patch removes code duplication for getting a catalog object
unique name by reusing the code from Catalog::toCatalogObjectKey(
TCatalogObject).

Testing:
- Ran all FE tests

Change-Id: I8218e57210c06fe6f2578a792d518e4b0287f15f
Reviewed-on: http://gerrit.cloudera.org:8080/11928
Reviewed-by: Impala Public Jenkins <im...@cloudera.com>
Tested-by: Impala Public Jenkins <im...@cloudera.com>


> Refactor Catalog::toCatalogObjectKey and CatalogObject::getUniqueName to reduce code repetition
> -----------------------------------------------------------------------------------------------
>
>                 Key: IMPALA-7839
>                 URL: https://issues.apache.org/jira/browse/IMPALA-7839
>             Project: IMPALA
>          Issue Type: Improvement
>          Components: Catalog
>            Reporter: Fredy Wijaya
>            Assignee: Fredy Wijaya
>            Priority: Minor
>
> Some examples of code repetition.
> https://github.com/apache/impala/blob/7299a6aedbbb7563e465dcfc6a20a981e9f1b804/fe/src/main/java/org/apache/impala/catalog/Catalog.java#L544-L582
> https://github.com/apache/impala/blob/7299a6aedbbb7563e465dcfc6a20a981e9f1b804/fe/src/main/java/org/apache/impala/catalog/PrincipalPrivilege.java#L146-L150
> https://github.com/apache/impala/blob/7299a6aedbbb7563e465dcfc6a20a981e9f1b804/fe/src/main/java/org/apache/impala/catalog/Table.java#L457-L458



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-all-unsubscribe@impala.apache.org
For additional commands, e-mail: issues-all-help@impala.apache.org