You are viewing a plain text version of this content. The canonical link for it is here.
Posted to docs@httpd.apache.org by Erik Abele <er...@codefaktor.de> on 2002/08/20 18:55:39 UTC

Re: Japanese internationalized error messages; charset intypemapfiles

on 20.08.2002 17:17 Uhr Hiroaki KAWAI (hawk@bcl.t.u-tokyo.ac.jp) wrote:

> I see. The idea of CONTENT_ENCODING seems to be nice.
> If we introduce the var, nagotiation of the docs in include/* will
> become unnecessary. The include/* would be common for all encodings.
> 
> But, we also have to change xml:lang="en" attribute to xml:lang="ja".
> Shall we introduce a new var CONTENT_LANG?

Hi Hiroaki,

uups, I forgot this one. In this case I would suggest to even introduce two
new vars; IMO CONTENT_LANG would be okay for this.

> By the way, is it OK, that xml:lang="en" are commonly used now whatever
> lang we choose (de,fr,etc)?

You're right. According to W3C "A special attribute named xml:lang _may be_
inserted in documents to specify the language used in the contents and
attribute values of any element in an XML document."
[http://www.w3.org/TR/REC-xml#sec-lang-tag]

If I get this right, we safely could leave out the xml:lang definition but
for the sake of correctness I would propose to take use of a new var to get
in a proper definition for all languages (en, de, fr, ja, etc.).

So, I'm +1 on introducing two new vars to get this working.

Erik

> 
> Erik Abele <er...@codefaktor.de> wrote:
>> We could also introduce an new variable (e.g. CONTENT_ENCODING) before
>> including top.html and set the correct encoding via the include/*.var's
> --snip--
>> and to get it in top.html:
>> 
>> <!--#if expr="! $CONTENT_ENCODING" -->
>> <!--#set var="CONTENT_ENCODING" value="ISO-8859-1" -->
>> <!--#endif -->
>> <?xml version="1.0" encoding="<!--#echo var="CONTENT_ENCODING" -->"?>
>> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
>> "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
>> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
>> <head>
>> <title><!--#echo var="TITLE" --></title>
>> <meta http-equiv="Content-Type" content="text/html; <!--#echo
>> var="CONTENT_ENCODING" -->" />
>> <link rev="made" href="mailto:<!--#echo encoding="none" var="SERVER_ADMIN"
>> -->" />
>> ...
>> 


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org


Re: Charset in type-maps /

Posted by Erik Abele <er...@codefaktor.de>.
on 20.08.2002 20:54 Uhr André Malo (nd@perlig.de) wrote:

> * Erik Abele wrote:
> 
>> So, I'm +1 on introducing two new vars to get this working.
> 
> +1 on $CONTENT_LANGUAGE
> -1 on $CONTENT_ENCODING
> 
> this var should be named CONTENT_CHARSET or similiar, because
> Content-Encoding has a complete different meaning. (e.g. gzip)
> 

+1, see last mail...

> Also the type maps themselves should be changed:
> 
> Content-language: de
> Content-type: text/html; charset=iso-8859-1
> (or whatever)
> 
> Another point: who needs the <meta> element? it's a bit oversized
> IMHO, because the information there is given in http header and in the
> <?xml?> pseudo element, too. We should consider to remove it.

Since the type maps are missing the correct charset definitions up to now,
we will have to rely on the encoding pseudo-attribute (<?xml ... ?>) or the
<meta>-tag.

Unfortunately I don't know the exact user-agent behaviors on this topic and
therefore I would suggest to keep the <meta> until the charset definitions
in the type maps are fixed.

Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org


Re: Japanese internationalized error messages; charsetintypemapfiles

Posted by André Malo <nd...@perlig.de>.
* Erik Abele wrote:

> So, I'm +1 on introducing two new vars to get this working.

+1 on $CONTENT_LANGUAGE
-1 on $CONTENT_ENCODING

this var should be named CONTENT_CHARSET or similiar, because
Content-Encoding has a complete different meaning. (e.g. gzip) 

Also the type maps themselves should be changed:

Content-language: de
Content-type: text/html; charset=iso-8859-1
(or whatever)

and, of course, the charset and $CONTENT_CHARSET should match ;-)

Another point: who needs the <meta> element? it's a bit oversized
IMHO, because the information there is given in http header and in the
<?xml?> pseudo element, too. We should consider to remove it. 

nd
-- 
s  s^saaaaaoaaaoaaaaooooaaoaaaomaaaa  a  alataa  aaoat  a  a
a maoaa a laoata  a  oia a o  a m a  o  alaoooat aaool aaoaa
matooololaaatoto  aaa o a  o ms;s;\s;s;g;y;s;:;s;y#mailto: #
 \51/\134\137| http://www.perlig.de #;print;# > nd@perlig.de

---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe@httpd.apache.org
For additional commands, e-mail: docs-help@httpd.apache.org