You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@lucene.apache.org by mi...@apache.org on 2013/09/05 22:58:18 UTC

svn commit: r1520422 - /lucene/dev/branches/lucene3069/lucene/core/src/java/org/apache/lucene/codecs/PostingsWriterBase.java

Author: mikemccand
Date: Thu Sep  5 20:58:17 2013
New Revision: 1520422

URL: http://svn.apache.org/r1520422
Log:
LUCENE-3069: small javadoc fixes

Modified:
    lucene/dev/branches/lucene3069/lucene/core/src/java/org/apache/lucene/codecs/PostingsWriterBase.java

Modified: lucene/dev/branches/lucene3069/lucene/core/src/java/org/apache/lucene/codecs/PostingsWriterBase.java
URL: http://svn.apache.org/viewvc/lucene/dev/branches/lucene3069/lucene/core/src/java/org/apache/lucene/codecs/PostingsWriterBase.java?rev=1520422&r1=1520421&r2=1520422&view=diff
==============================================================================
--- lucene/dev/branches/lucene3069/lucene/core/src/java/org/apache/lucene/codecs/PostingsWriterBase.java (original)
+++ lucene/dev/branches/lucene3069/lucene/core/src/java/org/apache/lucene/codecs/PostingsWriterBase.java Thu Sep  5 20:58:17 2013
@@ -69,19 +69,20 @@ public abstract class PostingsWriterBase
    * current term is delta encoded according to latest term. 
    * Usually elements in {@code longs} are file pointers, so each one always 
    * increases when a new term is consumed. {@code out} is used to write generic
-   * bytes, which are not monotonical.
+   * bytes, which are not monotonic.
    *
-   * NOTE: sometimes long[] might contain values that doesn't make sense, e.g. 
-   * the pointer to postings list may not be defined, if it is designed to inline 
-   * some postings data in term dictionary.  For this the postings side should 
-   * always use the last file pointer, so that each element in metadata long[] is 
-   * still monotonic.
+   * NOTE: sometimes long[] might contain "don't care" values that are unused, e.g. 
+   * the pointer to postings list may not be defined for some terms but is defined
+   * for others, if it is designed to inline  some postings data in term dictionary.
+   * In this case, the postings writer should always use the last value, so that each
+   * element in metadata long[] remains monotonic.
    */
   public abstract void encodeTerm(long[] longs, DataOutput out, FieldInfo fieldInfo, BlockTermState state, boolean absolute) throws IOException;
 
   /** 
-   * Return the fixed length of long[] metadata (which is fixed per field),
-   * called when the writing switches to another field. */
+   * Sets the current field for writing, and returns the
+   * fixed length of long[] metadata (which is fixed per
+   * field), called when the writing switches to another field. */
   // TODO: better name?
   public abstract int setField(FieldInfo fieldInfo);