You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Anubhav Dhoot (JIRA)" <ji...@apache.org> on 2015/04/21 22:58:59 UTC
[jira] [Commented] (YARN-3363) add localization and container
launch time to ContainerMetrics at NM to show these timing information for
each active container.
[ https://issues.apache.org/jira/browse/YARN-3363?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14505744#comment-14505744 ]
Anubhav Dhoot commented on YARN-3363:
-------------------------------------
The duration do not seem to belong in a ProcessTree class.
Can we instead of flowing the durations through the ProcessTree class, add the metrics directly in the ContainersMonitorImpl#handle by reading the startEvent.getLaunchDuration() directly?
Nit: ContainerMetrics:recordTime maybe could rename to recordStateChangeDurations or something to that effect?
sendContainerMonitorStartEvent has two different ways duration were calculated. Maybe make 2 local variables for launchDuration and localizationDuration and then we do not need the comment.
> add localization and container launch time to ContainerMetrics at NM to show these timing information for each active container.
> --------------------------------------------------------------------------------------------------------------------------------
>
> Key: YARN-3363
> URL: https://issues.apache.org/jira/browse/YARN-3363
> Project: Hadoop YARN
> Issue Type: Improvement
> Components: nodemanager
> Reporter: zhihai xu
> Assignee: zhihai xu
> Labels: metrics, supportability
> Attachments: YARN-3363.000.patch
>
>
> add localization and container launch time to ContainerMetrics at NM to show these timing information for each active container.
> Currently ContainerMetrics has container's actual memory usage(YARN-2984), actual CPU usage(YARN-3122), resource and pid(YARN-3022). It will be better to have localization and container launch time in ContainerMetrics for each active container.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)