You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Ksolves (Jira)" <ji...@apache.org> on 2024/06/24 09:26:00 UTC
[jira] [Commented] (KAFKA-6807) Inconsistent method name
[ https://issues.apache.org/jira/browse/KAFKA-6807?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17859629#comment-17859629 ]
Ksolves commented on KAFKA-6807:
--------------------------------
Its PR was created in 2018 and now has several conflicts. Thus I'll make a new PR.
> Inconsistent method name
> ------------------------
>
> Key: KAFKA-6807
> URL: https://issues.apache.org/jira/browse/KAFKA-6807
> Project: Kafka
> Issue Type: Improvement
> Reporter: KuiLIU
> Assignee: Ksolves
> Priority: Major
>
> The following method is named as "readTo", but the method will return the variable with lesses value. Thus, the name "readTo" is inconsistent with the method body code.
> Rename the method as "lesser" should be better.
> {code:java}
> private Long readTo(final long endOffset) {
> return endOffset < offsetLimit ? endOffset : offsetLimit;
> }
> {code}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)