You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@subversion.apache.org by ph...@apache.org on 2010/05/17 11:03:36 UTC

svn commit: r945034 - in /subversion/trunk/subversion: include/private/svn_wc_private.h libsvn_client/commit_util.c libsvn_wc/node.c

Author: philip
Date: Mon May 17 09:03:36 2010
New Revision: 945034

URL: http://svn.apache.org/viewvc?rev=945034&view=rev
Log:
* subversion/include/private/svn_wc_private.h
  (svn_wc__db_temp_get_keep_local): Renamed to ...
  (svn_wc__temp_get_keep_local): ... this.

* subversion/libsvn_wc/node.c
  (svn_wc__db_temp_get_keep_local): Renamed to ...
  (svn_wc__temp_get_keep_local): ... this.

* subversion/libsvn_client/commit_util.c
  (harvest_committables): Update call for rename.

Modified:
    subversion/trunk/subversion/include/private/svn_wc_private.h
    subversion/trunk/subversion/libsvn_client/commit_util.c
    subversion/trunk/subversion/libsvn_wc/node.c

Modified: subversion/trunk/subversion/include/private/svn_wc_private.h
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/include/private/svn_wc_private.h?rev=945034&r1=945033&r2=945034&view=diff
==============================================================================
--- subversion/trunk/subversion/include/private/svn_wc_private.h (original)
+++ subversion/trunk/subversion/include/private/svn_wc_private.h Mon May 17 09:03:36 2010
@@ -705,10 +705,10 @@ svn_wc__temp_mark_missing_not_present(co
 /* Return the @a *keep_local flag for local_abspath. (This flag will
    go away once we have a consolidated administrative area) */
 svn_error_t *
-svn_wc__db_temp_get_keep_local(svn_boolean_t *keep_local,
-                               svn_wc_context_t *wc_ctx,
-                               const char *local_abspath,
-                               apr_pool_t *scratch_pool);
+svn_wc__temp_get_keep_local(svn_boolean_t *keep_local,
+                            svn_wc_context_t *wc_ctx,
+                            const char *local_abspath,
+                            apr_pool_t *scratch_pool);
 
 #ifdef __cplusplus
 }

Modified: subversion/trunk/subversion/libsvn_client/commit_util.c
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/libsvn_client/commit_util.c?rev=945034&r1=945033&r2=945034&view=diff
==============================================================================
--- subversion/trunk/subversion/libsvn_client/commit_util.c (original)
+++ subversion/trunk/subversion/libsvn_client/commit_util.c Mon May 17 09:03:36 2010
@@ -470,8 +470,8 @@ harvest_committables(apr_hash_t *committ
         }
     }
 
-  SVN_ERR(svn_wc__db_temp_get_keep_local(&keep_local, ctx->wc_ctx,
-                                         local_abspath, scratch_pool));
+  SVN_ERR(svn_wc__temp_get_keep_local(&keep_local, ctx->wc_ctx,
+                                      local_abspath, scratch_pool));
   if (! keep_local)
     SVN_ERR(bail_on_tree_conflicted_children(ctx->wc_ctx, local_abspath,
                                              db_kind, depth, changelists,

Modified: subversion/trunk/subversion/libsvn_wc/node.c
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/libsvn_wc/node.c?rev=945034&r1=945033&r2=945034&view=diff
==============================================================================
--- subversion/trunk/subversion/libsvn_wc/node.c (original)
+++ subversion/trunk/subversion/libsvn_wc/node.c Mon May 17 09:03:36 2010
@@ -1106,10 +1106,10 @@ svn_wc__node_check_conflicts(svn_boolean
 }
 
 svn_error_t *
-svn_wc__db_temp_get_keep_local(svn_boolean_t *keep_local,
-                               svn_wc_context_t *wc_ctx,
-                               const char *local_abspath,
-                               apr_pool_t *scratch_pool)
+svn_wc__temp_get_keep_local(svn_boolean_t *keep_local,
+                            svn_wc_context_t *wc_ctx,
+                            const char *local_abspath,
+                            apr_pool_t *scratch_pool)
 {
   svn_boolean_t is_deleted;
 



Re: svn commit: r945034 - in /subversion/trunk/subversion: include/private/svn_wc_private.h libsvn_client/commit_util.c libsvn_wc/node.c

Posted by Philip Martin <ph...@wandisco.com>.
Greg Stein <gs...@gmail.com> writes:

> On Mon, May 17, 2010 at 05:03,  <ph...@apache.org> wrote:
>> Author: philip
>> Date: Mon May 17 09:03:36 2010
>> New Revision: 945034
>>
>> URL: http://svn.apache.org/viewvc?rev=945034&view=rev
>> Log:
>> * subversion/include/private/svn_wc_private.h
>>  (svn_wc__db_temp_get_keep_local): Renamed to ...
>>  (svn_wc__temp_get_keep_local): ... this.
>>
>> * subversion/libsvn_wc/node.c
>>  (svn_wc__db_temp_get_keep_local): Renamed to ...
>>  (svn_wc__temp_get_keep_local): ... this.
>
> Okay. This is better. But really... why was this ever named something
> *besides* svn_wc__node_foo. ? It lives in node.c just like all the
> other node functions. All node functions are temporary, by definition.
> I just don't understand the rationale for why it ever used a different
> namespace to start with.
>
> ??
>
>>...
>
> (not asking for change; just insight)

I simply got confused by our naming conventions.

-- 
Philip

Re: svn commit: r945034 - in /subversion/trunk/subversion: include/private/svn_wc_private.h libsvn_client/commit_util.c libsvn_wc/node.c

Posted by Greg Stein <gs...@gmail.com>.
On Mon, May 17, 2010 at 05:03,  <ph...@apache.org> wrote:
> Author: philip
> Date: Mon May 17 09:03:36 2010
> New Revision: 945034
>
> URL: http://svn.apache.org/viewvc?rev=945034&view=rev
> Log:
> * subversion/include/private/svn_wc_private.h
>  (svn_wc__db_temp_get_keep_local): Renamed to ...
>  (svn_wc__temp_get_keep_local): ... this.
>
> * subversion/libsvn_wc/node.c
>  (svn_wc__db_temp_get_keep_local): Renamed to ...
>  (svn_wc__temp_get_keep_local): ... this.

Okay. This is better. But really... why was this ever named something
*besides* svn_wc__node_foo. ? It lives in node.c just like all the
other node functions. All node functions are temporary, by definition.
I just don't understand the rationale for why it ever used a different
namespace to start with.

??

>...

(not asking for change; just insight)

Cheers,
-g