You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Gargi Jaiswal (Jira)" <ji...@apache.org> on 2025/08/18 08:37:00 UTC

[jira] [Updated] (HDDS-13586) [DiskBalancer] Refactor DiskBalancer to remove unused methods and improve naming

     [ https://issues.apache.org/jira/browse/HDDS-13586?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gargi Jaiswal updated HDDS-13586:
---------------------------------
    Summary: [DiskBalancer] Refactor DiskBalancer to remove unused methods and improve naming  (was: [DiskBalancer] Refactor DiskBalancer components, remove unused methods and improve naming)

> [DiskBalancer] Refactor DiskBalancer to remove unused methods and improve naming
> --------------------------------------------------------------------------------
>
>                 Key: HDDS-13586
>                 URL: https://issues.apache.org/jira/browse/HDDS-13586
>             Project: Apache Ozone
>          Issue Type: Sub-task
>            Reporter: Gargi Jaiswal
>            Assignee: Gargi Jaiswal
>            Priority: Minor
>
> *1. Improve data structures and type safety* :
>  * *DatanodeDiskBalancerInfoProto* should use *DatanodeIDProto* instead of
> {*}DatanodeDetailsProto{*}.
>  *  In {*}DiskBalancerService{*}, use *ContainerID* instead of *Long* for container id.
>  * Use *Objects.requireNonNull(..)* instead of {*}Preconditions.checkNotNull(..){*}.
> *2. Replace the use of Optional for method parameters in DiskBalancer:*
> As a general rule, parameters should be explicitly required or nullable, not wrapped in an Optional. For context, see: [https://www.reddit.com/r/java/comments/sat1j4/opinions_on_using_optional_as_parameter/]
> *3. Cleanup of Dead Code:*
>  * Remove *DatanodeDiskBalancerInfoType* since it is never used.
>  * Remove the new *Container.importContainerData(Path containerPath)* method since it is never used.
>  * Rename *Container.copyContainerData* to {*}copyContainerDirectory{*}. As, it sounds like copy/import the ContainerData class.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org