You are viewing a plain text version of this content. The canonical link for it is here.
Posted to log4j-dev@logging.apache.org by bu...@apache.org on 2007/07/11 00:34:19 UTC

DO NOT REPLY [Bug 42654] - Fixing 'tailing' in VFS log Receiver

DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG�
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=42654>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND�
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=42654





------- Additional Comments From psmith@apache.org  2007-07-10 15:34 -------
The only comments I can make here are:

* Constants should be extracted and named appropriately (for wait/sleep times). 

* Threads created should be given an appropriate name so that one can identify
their purpose easily in a thread dump or debug view

* Personally the anonymous Runnable inner-class implementation looks a bit long
to be anonymous.  Can we extract that into a separate private inner-class?  I
know this doesn't really get us anywhere but I find the code readability better
IMHO.

* I/O classes are not properly close()'d.  I think we probably should obey the
general I/O and execute the tidy up operations in appropriate finally blocks. 
On some platforms failing to do this can lead to dangling handles until the
process exits.  

(these were all here before your changes, but we might as well make it tidy
while we're here).

Scott, do you have other comments?  If I see these above changes in a new patch
I'd be ok to commit this.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org