You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@flink.apache.org by tw...@apache.org on 2022/04/08 15:21:15 UTC
[flink] branch release-1.15 updated: [hotfix][table-common] Use correct naming convention for TRY_CAST
This is an automated email from the ASF dual-hosted git repository.
twalthr pushed a commit to branch release-1.15
in repository https://gitbox.apache.org/repos/asf/flink.git
The following commit(s) were added to refs/heads/release-1.15 by this push:
new c825d6b82a3 [hotfix][table-common] Use correct naming convention for TRY_CAST
c825d6b82a3 is described below
commit c825d6b82a3b9c42fd88868f3334048e3a495db7
Author: Timo Walther <tw...@apache.org>
AuthorDate: Mon Mar 7 12:52:24 2022 +0100
[hotfix][table-common] Use correct naming convention for TRY_CAST
---
.../org/apache/flink/table/functions/BuiltInFunctionDefinitions.java | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/flink-table/flink-table-common/src/main/java/org/apache/flink/table/functions/BuiltInFunctionDefinitions.java b/flink-table/flink-table-common/src/main/java/org/apache/flink/table/functions/BuiltInFunctionDefinitions.java
index e9473768917..725d823a1bf 100644
--- a/flink-table/flink-table-common/src/main/java/org/apache/flink/table/functions/BuiltInFunctionDefinitions.java
+++ b/flink-table/flink-table-common/src/main/java/org/apache/flink/table/functions/BuiltInFunctionDefinitions.java
@@ -1720,7 +1720,7 @@ public final class BuiltInFunctionDefinitions {
public static final BuiltInFunctionDefinition TRY_CAST =
BuiltInFunctionDefinition.newBuilder()
- .name("tryCast")
+ .name("TRY_CAST")
.kind(SCALAR)
.inputTypeStrategy(SpecificInputTypeStrategies.CAST)
.outputTypeStrategy(forceNullable(TypeStrategies.argument(1)))