You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Pranay Varma (JIRA)" <ji...@apache.org> on 2013/06/23 02:34:19 UTC
[jira] [Updated] (MAPREDUCE-5342) mapProgress method in the Job
class should be deprecated and a new method called getMapProgress should be
added
[ https://issues.apache.org/jira/browse/MAPREDUCE-5342?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Pranay Varma updated MAPREDUCE-5342:
------------------------------------
Description:
Job.mapProgress suggests that the method is going to map progress and is misleading because, in fact, the method provides progress information about map tasks. It should be deprecated and a method should be added with a name that matches the purpose: getMapTasksProgress or getMapProgress.
The same applies to the following methods in the Job class:
getReduceProgress, getCleanupProgress.
was:mapProgress suggests that the method is going to map progress and is misleading because, in fact, the method provides progress information about map tasks. It should be renamed to match what it does: getMapTasksProgress.
Summary: mapProgress method in the Job class should be deprecated and a new method called getMapProgress should be added (was: mapProgress should be renamed getMapTasksProgress)
> mapProgress method in the Job class should be deprecated and a new method called getMapProgress should be added
> ---------------------------------------------------------------------------------------------------------------
>
> Key: MAPREDUCE-5342
> URL: https://issues.apache.org/jira/browse/MAPREDUCE-5342
> Project: Hadoop Map/Reduce
> Issue Type: Bug
> Components: jobtracker
> Affects Versions: 2.1.0-beta, 2.0.5-alpha
> Environment: Does not matter
> Reporter: Pranay Varma
>
> Job.mapProgress suggests that the method is going to map progress and is misleading because, in fact, the method provides progress information about map tasks. It should be deprecated and a method should be added with a name that matches the purpose: getMapTasksProgress or getMapProgress.
> The same applies to the following methods in the Job class:
> getReduceProgress, getCleanupProgress.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira