You are viewing a plain text version of this content. The canonical link for it is here.
Posted to oak-dev@jackrabbit.apache.org by "Michael Dürig (Assigned JIRA)" <ji...@apache.org> on 2012/03/12 18:19:38 UTC
[jira] [Assigned] (OAK-10) Impedance mismatch between signatures of
NodeState#getChildeNodeEntries and MicroKernel#getNodes
[ https://issues.apache.org/jira/browse/OAK-10?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Michael Dürig reassigned OAK-10:
--------------------------------
Assignee: Michael Dürig
> Impedance mismatch between signatures of NodeState#getChildeNodeEntries and MicroKernel#getNodes
> ------------------------------------------------------------------------------------------------
>
> Key: OAK-10
> URL: https://issues.apache.org/jira/browse/OAK-10
> Project: Jackrabbit Oak
> Issue Type: Improvement
> Reporter: Michael Dürig
> Assignee: Michael Dürig
> Fix For: 0.1
>
>
> NodeState#getChildeNodeEntries uses long for its lenght parameter while MicroKernel#getNodes uses int. In order to implement the NodeState interface on top of the Microkernel, it would be favourable if the type would be the same.
> I suggest we change it to int for both methods since a length bigger than Integer.MAX_VALUE is not realistic anyway. On a related note, I'd rename the parameter from length to count.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira