You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@thrift.apache.org by "Bhasker Kode (JIRA)" <ji...@apache.org> on 2015/01/04 18:28:34 UTC
[jira] [Created] (THRIFT-2928) Rename the erlang test_server module
Bhasker Kode created THRIFT-2928:
------------------------------------
Summary: Rename the erlang test_server module
Key: THRIFT-2928
URL: https://issues.apache.org/jira/browse/THRIFT-2928
Project: Thrift
Issue Type: Improvement
Components: Erlang - Library
Reporter: Bhasker Kode
Priority: Minor
erlang/otp began shipping with an app called *test_server* since November 2009 with R13B03. The current version of erlang/otp is approaching R18.
Thrift's test also comes with test_server.erl at {{lib/erl/test/test_server.erl}} as well as a test_client.erl
after compiling Thrift's erlang modules, I was expecting to find {{test_server:go/0}} but instead found functions from {{https://github.com/erlang/otp/blob/master/lib/test_server/src/test_server.erl}}
To avoid such conflicts while developing and in erlang deployments/releases, {{test_server.erl}} can be renamed as {{thrift_test_server.erl}}. For uniformity, {{test_client.erl}} can be renamed {{thrift_test_client.erl}} as well.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)