You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@madlib.apache.org by "Frank McQuillan (JIRA)" <ji...@apache.org> on 2019/05/06 19:14:00 UTC

[jira] [Commented] (MADLIB-1324) DL naming improvements for `dependent_varname` and `independent_varname`

    [ https://issues.apache.org/jira/browse/MADLIB-1324?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16834128#comment-16834128 ] 

Frank McQuillan commented on MADLIB-1324:
-----------------------------------------

LGTM

{code}
SELECT madlib.madlib_keras_fit('mnist_train_packed',  -- source_table
                               'model1', -- model
                               'model_arch_library',  -- model_arch_table
                               1,  -- model_arch_id
                               $$ loss='categorical_crossentropy', optimizer='adam', metrics=['acc'] $$,  -- compile_params
                               $$ batch_size=128, epochs=4 $$,  -- fit_params
                               5,  -- num_iterations
                               FALSE,  -- use_gpu
                               NULL,  -- validation_table
                               'Frank',  -- name
                               'A test model'  -- description
                              );
{code}
produces a model

> DL naming improvements for `dependent_varname` and `independent_varname`
> ------------------------------------------------------------------------
>
>                 Key: MADLIB-1324
>                 URL: https://issues.apache.org/jira/browse/MADLIB-1324
>             Project: Apache MADlib
>          Issue Type: Improvement
>          Components: Module: Neural Networks
>            Reporter: Frank McQuillan
>            Priority: Minor
>             Fix For: v1.16
>
>
> - use original column names from the source table (i.e., pre minibatch) in summary table, not the generic names `dependent_varname` and `independent_varname`
> - remove `dependent_varname` and `independent_varname` from the `fit()` interface since we know what these are from the minibatch summary table, and user must use minibatching for DL



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)