You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Greg Hudson <gh...@MIT.EDU> on 2005/06/24 02:35:57 UTC

Re: svn commit: r15157 - trunk/subversion/libsvn_subr

On Thu, 2005-06-23 at 19:02 -0500, jszakmeister@tigris.org wrote:
> -              if (strcmp (this_entry.name, dst_basename) == 0)
> -                 continue;
> +              if (strcmp (src, dst_parent) == 0
> +                  && strcmp (this_entry.name, dst_basename) == 0)
> +                {
> +                  continue;
> +                }

Uh... why did you add the braces?


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: r15157 - trunk/subversion/libsvn_subr

Posted by John Szakmeister <jo...@szakmeister.net>.
On Sunday 26 June 2005 14:20, Branko Čibej wrote:
> John Szakmeister wrote:
> >On Thursday 23 June 2005 22:35, Greg Hudson wrote:
> >>On Thu, 2005-06-23 at 19:02 -0500, jszakmeister@tigris.org wrote:
> >>>-              if (strcmp (this_entry.name, dst_basename) == 0)
> >>>-                 continue;
> >>>+              if (strcmp (src, dst_parent) == 0
> >>>+                  && strcmp (this_entry.name, dst_basename) == 0)
> >>>+                {
> >>>+                  continue;
> >>>+                }
> >>
> >>Uh... why did you add the braces?
> >
> >It was a little hard to read without them.  It started looking like
> >continue was more like part of the if statement than the block that
> > was to be executed as a result.
>
> Then you should've fixed the indentation, which was 2 columns instead
> of 2.

Fixed in r15175.

-John

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org


Re: svn commit: r15157 - trunk/subversion/libsvn_subr

Posted by Branko Čibej <br...@xbc.nu>.
John Szakmeister wrote:

>On Thursday 23 June 2005 22:35, Greg Hudson wrote:
>  
>
>>On Thu, 2005-06-23 at 19:02 -0500, jszakmeister@tigris.org wrote:
>>    
>>
>>>-              if (strcmp (this_entry.name, dst_basename) == 0)
>>>-                 continue;
>>>+              if (strcmp (src, dst_parent) == 0
>>>+                  && strcmp (this_entry.name, dst_basename) == 0)
>>>+                {
>>>+                  continue;
>>>+                }
>>>      
>>>
>>Uh... why did you add the braces?
>>    
>>
>
>It was a little hard to read without them.  It started looking like 
>continue was more like part of the if statement than the block that was 
>to be executed as a result.
>  
>
Then you should've fixed the indentation, which was 2 columns instead of 2.

-- Brane


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: r15157 - trunk/subversion/libsvn_subr

Posted by John Szakmeister <jo...@szakmeister.net>.
On Thursday 23 June 2005 22:35, Greg Hudson wrote:
> On Thu, 2005-06-23 at 19:02 -0500, jszakmeister@tigris.org wrote:
> > -              if (strcmp (this_entry.name, dst_basename) == 0)
> > -                 continue;
> > +              if (strcmp (src, dst_parent) == 0
> > +                  && strcmp (this_entry.name, dst_basename) == 0)
> > +                {
> > +                  continue;
> > +                }
>
> Uh... why did you add the braces?

It was a little hard to read without them.  It started looking like 
continue was more like part of the if statement than the block that was 
to be executed as a result.

-John

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org