You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hudi.apache.org by "sivabalan narayanan (Jira)" <ji...@apache.org> on 2025/02/01 05:11:02 UTC

[jira] [Updated] (HUDI-8419) Simplify definition of PAYLOAD_CLASS_NAME

     [ https://issues.apache.org/jira/browse/HUDI-8419?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

sivabalan narayanan updated HUDI-8419:
--------------------------------------
    Fix Version/s: 1.0.2

> Simplify definition of PAYLOAD_CLASS_NAME
> -----------------------------------------
>
>                 Key: HUDI-8419
>                 URL: https://issues.apache.org/jira/browse/HUDI-8419
>             Project: Apache Hudi
>          Issue Type: Sub-task
>            Reporter: Y Ethan Guo
>            Priority: Critical
>             Fix For: 1.0.1, 1.0.2
>
>
> PAYLOAD_CLASS_NAME ("hoodie.compaction.payload.class") is defined in both HoodiePayloadConfig and HoodieTableConfig.  They are used in different places.  We should keep one of them only to avoid confusion.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)