You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bookkeeper.apache.org by "Matthieu Morel (JIRA)" <ji...@apache.org> on 2011/08/30 12:23:37 UTC

[jira] [Created] (BOOKKEEPER-60) confusion between multiple "consume" methods

confusion between multiple "consume" methods
--------------------------------------------

                 Key: BOOKKEEPER-60
                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
             Project: Bookkeeper
          Issue Type: Improvement
          Components: hedwig-client
            Reporter: Matthieu Morel
            Priority: Minor


There are currently 2 methods named "consume" in the client API:
- in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
- in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.

I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.

Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (BOOKKEEPER-60) confusion between multiple "consume" methods

Posted by "Flavio Junqueira (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Flavio Junqueira resolved BOOKKEEPER-60.
----------------------------------------

    Resolution: Duplicate

Solved in BOOKKEEPER-90.
                
> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>             Fix For: 4.0.0
>
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-60) confusion between multiple "consume" methods

Posted by "Ivan Kelly (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13095844#comment-13095844 ] 

Ivan Kelly commented on BOOKKEEPER-60:
--------------------------------------

Done. Still not sure how to do it though. Usually you deprecate for 1 release and then remove in the next. However, in this case, deprecation isn't an option.

> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>             Fix For: 4.0.0
>
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-60) confusion between multiple "consume" methods

Posted by "Ivan Kelly (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ivan Kelly updated BOOKKEEPER-60:
---------------------------------

    Fix Version/s:     (was: 4.0.0)
    
> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-60) confusion between multiple "consume" methods

Posted by "Ivan Kelly (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13095380#comment-13095380 ] 

Ivan Kelly commented on BOOKKEEPER-60:
--------------------------------------

I think Subscribe.consume is correct. I'd change MessageHandler#consume to MessageHandler#deliver instead. However, this would be an API change, which Im not sure how to do. If I remember correct, we only make API breaks between major versions, so this would have to go in 4.0.0, which I think could be a long way away. 

> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-60) confusion between multiple "consume" methods

Posted by "Matthieu Morel (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13095404#comment-13095404 ] 

Matthieu Morel commented on BOOKKEEPER-60:
------------------------------------------

I don't see any 4.0.0 scheduled version. It would probably be worth creating it and specifying it as the fix version for this issue (and others like it).

> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-60) confusion between multiple "consume" methods

Posted by "Ivan Kelly (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-60?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ivan Kelly updated BOOKKEEPER-60:
---------------------------------

    Fix Version/s: 4.0.0

> confusion between multiple "consume" methods
> --------------------------------------------
>
>                 Key: BOOKKEEPER-60
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-60
>             Project: Bookkeeper
>          Issue Type: Improvement
>          Components: hedwig-client
>            Reporter: Matthieu Morel
>            Priority: Minor
>             Fix For: 4.0.0
>
>
> There are currently 2 methods named "consume" in the client API:
> - in org.apache.hedwig.client.api.MessageHandler : delegates the processing of a message by a message handler
> - in org.apache.hedwig.client.api.Subscriber : notifies the server that messages have been processed till a given sequence id. This is some kind of acknowledgement.
> I don't think these 2 fundamental methods should be named the same: they have different purposes and it is confusing.
> Couldn't we rename Subscriber.consume into Subscriber.acknowledge, or something similar?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira