You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Ravi Prakash (JIRA)" <ji...@apache.org> on 2017/06/13 07:07:00 UTC

[jira] [Resolved] (HADOOP-14513) A little performance improvement of HarFileSystem

     [ https://issues.apache.org/jira/browse/HADOOP-14513?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ravi Prakash resolved HADOOP-14513.
-----------------------------------
    Resolution: Not A Problem

> A little performance improvement of HarFileSystem
> -------------------------------------------------
>
>                 Key: HADOOP-14513
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14513
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 3.0.0-alpha3
>            Reporter: hu xiaodong
>            Assignee: hu xiaodong
>            Priority: Trivial
>         Attachments: HADOOP-14513.001.patch
>
>
> In the Java source of HarFileSystem.java:
> {code:title=HarFileSystem.java|borderStyle=solid}
> ...................
> ...................
> private Path archivePath(Path p) {
>     Path retPath = null;
>     Path tmp = p;
>     
>     // I think p.depth() need not be loop many times, depth() is a complex calculation
>     for (int i=0; i< p.depth(); i++) {
>       if (tmp.toString().endsWith(".har")) {
>         retPath = tmp;
>         break;
>       }
>       tmp = tmp.getParent();
>     }
>     return retPath;
>   }
> ...................
> ...................
> {code}
>  
> I think the fellow is more suitable:
> {code:title=HarFileSystem.java|borderStyle=solid}
> ...................
> ...................
> private Path archivePath(Path p) {
>     Path retPath = null;
>     Path tmp = p;
>     
>     // just loop once
>     for (int i=0,depth=p.depth(); i< depth; i++) {
>       if (tmp.toString().endsWith(".har")) {
>         retPath = tmp;
>         break;
>       }
>       tmp = tmp.getParent();
>     }
>     return retPath;
>   }
> ...................
> ...................
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-dev-help@hadoop.apache.org