You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Bernd Mathiske <be...@mesosphere.io> on 2015/08/03 10:52:13 UTC

Re: Review Request 36847: Added HTTP Delete Method.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36847/#review93880
-----------------------------------------------------------



3rdparty/libprocess/include/process/http.hpp (line 736)
<https://reviews.apache.org/r/36847/#comment148297>

    (We have discussed this naming choice at some length offline. Here is how I see it.) If I find a call site somewhere that reads "http:del(...)" I will probably wonder what this is and will look it up. Not good enough IMHO. Cryptic.
    
    If instead I read "http::sendDeleteRequest()", it is immediately clear to me what this call does. 
    
    True, this makes the API unbalanced, since the other calls are simply called "get" and "put". Well, they never should have! 
    
    Even if we never rename the other calls, I favor readability at call sites over superficially consistent naming across the API.
    
    2c


- Bernd Mathiske


On July 29, 2015, 6:39 a.m., Joerg Schad wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36847/
> -----------------------------------------------------------
> 
> (Updated July 29, 2015, 6:39 a.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov and Bernd Mathiske.
> 
> 
> Bugs: MESOS-3152
>     https://issues.apache.org/jira/browse/MESOS-3152
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> see summary.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/process/http.hpp 9faed55247a3ccd629db7b85dbf31d3117e120e9 
>   3rdparty/libprocess/src/http.cpp d1685799f4c53e067d0812e037e171324ee7195f 
>   3rdparty/libprocess/src/tests/http_tests.cpp 01f243cd9c46e162c16e9bb452a846faf31d1445 
> 
> Diff: https://reviews.apache.org/r/36847/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Joerg Schad
> 
>