You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Jie Yu <yu...@gmail.com> on 2014/12/03 04:05:09 UTC

Review Request 28627: Added tests for basic DiskInfo checker.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/28627/
-----------------------------------------------------------

Review request for mesos and Ben Mahler.


Bugs: MESOS-2030
    https://issues.apache.org/jira/browse/MESOS-2030


Repository: mesos-git


Description
-------

Added tests for basic DiskInfo checker.


Diffs
-----

  src/common/protobuf_utils.hpp bc3ef2a5f4e80c511d19cff6a4fb822c8d247571 
  src/common/protobuf_utils.cpp baf04a6434e6f19e7e06e98c2d7795f87087eb0b 
  src/tests/resource_offers_tests.cpp c8c25d75d93b6e9e25d35cb9953f9c91dfbbbd14 

Diff: https://reviews.apache.org/r/28627/diff/


Testing
-------

make check


Thanks,

Jie Yu


Re: Review Request 28627: Added tests for basic DiskInfo checker.

Posted by Mesos ReviewBot <de...@mesos.apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/28627/#review63642
-----------------------------------------------------------


Patch looks great!

Reviews applied: [28616, 28618, 28626, 28627]

All tests passed.

- Mesos ReviewBot


On Dec. 3, 2014, 3:05 a.m., Jie Yu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/28627/
> -----------------------------------------------------------
> 
> (Updated Dec. 3, 2014, 3:05 a.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Bugs: MESOS-2030
>     https://issues.apache.org/jira/browse/MESOS-2030
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Added tests for basic DiskInfo checker.
> 
> 
> Diffs
> -----
> 
>   src/common/protobuf_utils.hpp bc3ef2a5f4e80c511d19cff6a4fb822c8d247571 
>   src/common/protobuf_utils.cpp baf04a6434e6f19e7e06e98c2d7795f87087eb0b 
>   src/tests/resource_offers_tests.cpp c8c25d75d93b6e9e25d35cb9953f9c91dfbbbd14 
> 
> Diff: https://reviews.apache.org/r/28627/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Jie Yu
> 
>


Re: Review Request 28627: Added tests for basic DiskInfo checker.

Posted by Ben Mahler <be...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/28627/#review63732
-----------------------------------------------------------

Ship it!


Thanks for the tests!

All of the task validation tests do the same thing: launch a task, expect an update of a particular format (invalid w/ message). Mind adding a TODO to provide some functionality in the test fixtue to at least remove all of the test code bloat here? This would make the tests a lot easier to read, without having to do the hard work of refactoring our validation to be more unit testable.


src/common/protobuf_utils.hpp
<https://reviews.apache.org/r/28627/#comment106026>

    Can you move this into a test file instead of protobuf_utils? Maybe in the test fixture? Doesn't look generally useful, for now.
    
    All of these other ones are used within the non-test code.



src/common/protobuf_utils.cpp
<https://reviews.apache.org/r/28627/#comment106022>

    Do you need this comment? ;)



src/common/protobuf_utils.cpp
<https://reviews.apache.org/r/28627/#comment106023>

    Do you need this comment? ;)



src/tests/resource_offers_tests.cpp
<https://reviews.apache.org/r/28627/#comment106031>

    How about 'UnreservedDiskInfo'?


- Ben Mahler


On Dec. 3, 2014, 3:05 a.m., Jie Yu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/28627/
> -----------------------------------------------------------
> 
> (Updated Dec. 3, 2014, 3:05 a.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Bugs: MESOS-2030
>     https://issues.apache.org/jira/browse/MESOS-2030
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Added tests for basic DiskInfo checker.
> 
> 
> Diffs
> -----
> 
>   src/common/protobuf_utils.hpp bc3ef2a5f4e80c511d19cff6a4fb822c8d247571 
>   src/common/protobuf_utils.cpp baf04a6434e6f19e7e06e98c2d7795f87087eb0b 
>   src/tests/resource_offers_tests.cpp c8c25d75d93b6e9e25d35cb9953f9c91dfbbbd14 
> 
> Diff: https://reviews.apache.org/r/28627/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Jie Yu
> 
>