You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@reef.apache.org by "Mariia Mykhailova (JIRA)" <ji...@apache.org> on 2015/10/06 23:31:27 UTC

[jira] [Commented] (REEF-531) Add missing Javadoc comments/triage TODO notes in Java code: reef-tang

    [ https://issues.apache.org/jira/browse/REEF-531?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14945857#comment-14945857 ] 

Mariia Mykhailova commented on REEF-531:
----------------------------------------

[~markus.weimer], all these TODOs were in 
{noformat}
2e3c69b Markus Weimer on 10/22/2014 at 2:02 PM
Add 'reef-tang/' from commit 'd1189772da479577b1b8501c8a2b5eb30e9d0836'
{noformat}
Please help triage/find the appropriate authors

{noformat}
org/apache/reef/tang/Configuration.java
* TODO: Should this return Set<ConstructorDef<T>> instead?
<T> ConstructorDef<T> getLegacyConstructor(ClassNode<T> cn);

org/apache/reef/tang/Tang.java
* @TODO Is the class hierarchy returned here backed by the default
* classloader or not?  If not, then callers will need to merge it with
* getDefaultClassHierarchy().  If so, we should add a new method like
* getNonDefaultClassHiearchy() that takes the same options as this one.

org/apache/reef/tang/TestBindSingleton.java
// TODO: Should we require bind(A,B), then bind(B,B) if B has subclasses?

org/apache/reef/tang/TestListInjection.java
// TODO: Make tests for list serialization/deserialization after implementing those features.

org/apache/reef/tang/TestTang.java
// TODO: Delete this?  (It is handled in TestClassHierarchy!)
public void testRepeatedAmbiguousArgs()

org/apache/reef/tang/formats/CommandLine.java
// TODO: Check for conflicting options.

org/apache/reef/tang/implementation/ConfigurationBuilderImpl.java
// TODO: None of these should be public! - Move to configurationBuilder. Have
// that wrap itself
// in a sane Configuration interface...
// TODO: Should be final again!

org/apache/reef/tang/implementation/Constructor.java
* TODO: use ArrayList internally (and maybe for input, too).

org/apache/reef/tang/implementation/Subplan.java
* TODO: use ArrayList internally (and maybe for input, too).

org/apache/reef/tang/implementation/TestClassHierarchy.java
// TODO: The next three error messages should be more specific about the underlying cause of the failure.

org/apache/reef/tang/implementation/java/ClassHierarchyImpl.java
// TODO Want to add a "register namespace" method, but Java is not designed
// to support such things.
// There are third party libraries that would help, but they can fail if the
// relevant jar has not yet been loaded.  Tint works around this using such
// a library.

// TODO: When handling sets, need to track target of generic parameter, and check the type here!

org/apache/reef/tang/implementation/java/InjectorImpl.java
// TODO: We should be insisting on injection futures here! .forkInjector();

// TODO: Must be named parameter node.  Check.

org/apache/reef/tang/implementation/java/JavaNodeFactory.java
// TODO: When we use paramTypes below, we strip generic parameters.  Is that OK?

org/apache/reef/tang/implementation/types/ConstructorDefImpl.java
* TODO could be faster. Currently O(n^2) in number of parameters.

org/apache/reef/tang/util/ReflectionUtilities.java
* TODO: Float and double are currently coercible to int and long.  This is a bug.

* TODO This is only tested for interfaces, and the type parameters associated with method arguments.
* TODO Not sure what we should do in the face of deeply nested generics (eg: Set<Set<String>)
* TODO Recurse up the class hierarchy in case there are intermediate interfaces

// TODO Figure out how to properly differentiate between default and
// non-default zero-arg constructors?

org/apache/reef/tang/util/Tint.java
// TODO Auto-generated catch block

// TODO: Documentation string?
{noformat}
----
{noformat}
org/apache/reef/tang/test/ObjectTreeTest.java
public static Configuration getConfigurationWithoutList() throws BindException {
// TODO: Remove this method after #192 is fixed

org/apache/reef/tang/test/RootImplementationWithoutList.java
// TODO: Remove this class after #192 is fixed

org/apache/reef/tang/test/RoundTripTest.java
// TODO: use 'getConfiguration' instead of 'getConfigurationWithoutList' after #192 is fixed

org/apache/reef/tang/test/TestConfigurationWithoutList.java
// TODO: Remove this method after #192 is fixed
{noformat}

> Add missing Javadoc comments/triage TODO notes in Java code: reef-tang
> ----------------------------------------------------------------------
>
>                 Key: REEF-531
>                 URL: https://issues.apache.org/jira/browse/REEF-531
>             Project: REEF
>          Issue Type: Sub-task
>          Components: Tang
>            Reporter: Mariia Mykhailova
>            Priority: Minor
>
> See parent JIRA for description



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)