You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commons-dev@ws.apache.org by "Davanum Srinivas (JIRA)" <ji...@apache.org> on 2007/02/01 04:24:06 UTC
[jira] Updated: (WSCOMMONS-45) PolicyUtil.matchByQName defect when
lists are the same size
[ https://issues.apache.org/jira/browse/WSCOMMONS-45?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Davanum Srinivas updated WSCOMMONS-45:
--------------------------------------
Assignee: Sanka Samaranayake
> PolicyUtil.matchByQName defect when lists are the same size
> -----------------------------------------------------------
>
> Key: WSCOMMONS-45
> URL: https://issues.apache.org/jira/browse/WSCOMMONS-45
> Project: WS-Commons
> Issue Type: Bug
> Components: Policy
> Reporter: David Waite
> Assigned To: Sanka Samaranayake
>
> The following lines:
> List larger = (primTermsA.size() > primTermsB.size()) ? primTermsA
> : primTermsB;
> List smaller = (primTermsA.size() < primTermsB.size()) ? primTermsA
> : primTermsB;
> Will cause larger and smaller to both be set to primTermsB when the lists are of the same size. This can be solved by changing one of the comparisons to either >= or <=, or (perhaps more ideally for readability) making the statements in an if block.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: commons-dev-help@ws.apache.org