You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Daryn Sharp (JIRA)" <ji...@apache.org> on 2016/10/03 22:03:20 UTC

[jira] [Commented] (HDFS-10930) Refactor Datanode IO operations into a single class

    [ https://issues.apache.org/jira/browse/HDFS-10930?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15543564#comment-15543564 ] 

Daryn Sharp commented on HDFS-10930:
------------------------------------

I hope I'm misunderstanding this jira.  Are you actually proposing to merge all those classes into a single mega-class?  If yes, that gets a big (n).  Else please elaborate.

> Refactor Datanode IO operations into a single class
> ---------------------------------------------------
>
>                 Key: HDFS-10930
>                 URL: https://issues.apache.org/jira/browse/HDFS-10930
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>            Reporter: Xiaoyu Yao
>            Assignee: Xiaoyu Yao
>
> Datanode IO (Disk/Network) related operations and instrumentations are currently spilled in many classes such as DataNode.java, BlockReceiver.java, BlockSender.java, FsDatasetImpl.java, FsVolumeImpl.java, DirectoryScanner.java, BlockScanner.java, FsDatasetAsyncDiskService.java, LocalReplica.java, LocalReplicaPipeline.java, Storage.java, etc. This ticket is opened to consolidate them into a single class. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org