You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Zhe Zhang (JIRA)" <ji...@apache.org> on 2015/06/24 00:57:42 UTC
[jira] [Created] (HDFS-8655) Refactor accesses to INodeFile#blocks
Zhe Zhang created HDFS-8655:
-------------------------------
Summary: Refactor accesses to INodeFile#blocks
Key: HDFS-8655
URL: https://issues.apache.org/jira/browse/HDFS-8655
Project: Hadoop HDFS
Issue Type: Improvement
Components: namenode
Affects Versions: 2.7.0
Reporter: Zhe Zhang
Assignee: Zhe Zhang
When enabling INodeFile support for striped blocks (mainly in HDFS-7749), HDFS-7285 branch generalized the concept of blocks under an inode. Now {{INodeFile#blocks}} only contains contiguous blocks of an inode. This JIRA separates out code refactors for this purpose. Two main changes:
# Rename {{setBlocks}} to {{setContiguousBlocks}}
# Replace direct accesses to {{INodeFile#blocks}} to {{getBlocks}}
It also contains some code cleanups introduced in the branch.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)