You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Philip Martin <ph...@codematters.co.uk> on 2002/11/11 12:01:47 UTC

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

kfogel@tigris.org writes:

> Modified: trunk/subversion/clients/cmdline/main.c
> ==============================================================================
> --- trunk/subversion/clients/cmdline/main.c	(original)
> +++ trunk/subversion/clients/cmdline/main.c	Sun Nov 10 18:46:05 2002
> @@ -88,6 +88,16 @@
>                        "do no interactive prompting"},
>      {"dry-run",       svn_cl__dry_run_opt, 0,
>                        "try operation but make no changes"},
> +
> +    /* ### Perhaps the option should be named "--rev-prop" instead?
> +           Generally, we do include the hyphen; the only reason not to
> +           here is that in code and emails we almost always refer to
> +           them as "revprops", like with "wcprops".  So this
> +           inconsistency is justified in the name of consistency.  How
> +           distressingly typical.  Thoughts? :-) */
> +    {"revprop",       svn_cl__revprop_opt, 0,
> +                      "operate on a revision property (use with -r)"},
> +

How about using --repository and changing the help text to refer to
"repository property"? 

   svn ps --repository -r123 svn:log "tag version 0.9"

-- 
Philip Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Colin Watson <cj...@flatline.org.uk>.
On Mon, Nov 11, 2002 at 10:20:57AM -0600, Karl Fogel wrote:
> Anyway, yes, good point.  I'm not totally thrilled with "--revprop",
> but it's descriptive, and more accurate than "--repository".
> 
> Any other ideas, folks?

How about "--unversioned"?

-- 
Colin Watson                                  [cjwatson@flatline.org.uk]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Karl Fogel <kf...@newton.ch.collab.net>.
Greg Hudson <gh...@MIT.EDU> writes:
> > How about using --repository and changing the help text to refer to
> > "repository property"? 
> 
> How is it a repository property?  That suggests a single property list
> tied to the entire repository, instead of a property list tied to a
> particular revision.  Or it suggests "make this change in the
> repository, not in the working dir," which is content-free for this
> operation.

Wow, I am getting really suggestible lately :-).

When Philip wrote "repository", I somehow interpreted it to mean
"revision".  Even though repository clearly does not mean revision,
and we already have word that means revision, and it is revision :-).

Must be because they both begin with 'r'.

Anyway, yes, good point.  I'm not totally thrilled with "--revprop",
but it's descriptive, and more accurate than "--repository".

Any other ideas, folks?

-K

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Karl Fogel <kf...@newton.ch.collab.net>.
Philip Martin <ph...@codematters.co.uk> writes:
> I can't argue this one, other than to say that it is a user error, and
> users make errors :)  I still prefer --repository and find  --revprop
> ugly.

Consider

   $ svn propget -r 3 foo bar qux.c
   $ svn propget --repository -r 3 foo bar qux.c

These do different things, yet both operate on the repository, and
both take -r (though only for the latter is -r actually required).

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Philip Martin <ph...@codematters.co.uk>.
Greg Hudson <gh...@MIT.EDU> writes:

> On Mon, 2002-11-11 at 12:00, Philip Martin wrote:
> > > How is it a repository property?
> > 
> > It associated with the repository as a whole, and not with any
> > individual file or directory within the repository.  
> 
> That would make sense if we carried revision properties forward like we
> do for files and directories.  But we don't; setting property "foo" to
> "bar" on revision 100 doesn't cause "foo" to be set on revision 101. 
> These really are separate property lists hanging off the revisions, not
> a single versioned property list hanging off the repository.

So the scenario is that the user runs

   svn ps --repository --revision 100 foo bar

and erroneously expects it to affect revisions other than 100.

Is changing "repository" into "revprop" really going to correct this
misunderstanding?

I'm giving up, I don't really care one way or the other :)

-- 
Philip Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Greg Hudson <gh...@MIT.EDU>.
On Mon, 2002-11-11 at 12:00, Philip Martin wrote:
> > How is it a repository property?
> 
> It associated with the repository as a whole, and not with any
> individual file or directory within the repository.  

That would make sense if we carried revision properties forward like we
do for files and directories.  But we don't; setting property "foo" to
"bar" on revision 100 doesn't cause "foo" to be set on revision 101. 
These really are separate property lists hanging off the revisions, not
a single versioned property list hanging off the repository.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Philip Martin <ph...@codematters.co.uk>.
Greg Hudson <gh...@MIT.EDU> writes:

> On Mon, 2002-11-11 at 07:01, Philip Martin wrote:
> > How about using --repository and changing the help text to refer to
> > "repository property"? 
> 
> How is it a repository property?

It associated with the repository as a whole, and not with any
individual file or directory within the repository.  

>  That suggests a single property list
> tied to the entire repository, instead of a property list tied to a
> particular revision

The commands require a --revison argument, they won't run without one,
it can't be that difficult to determine that the revision is
important.

>  Or it suggests "make this change in the
> repository, not in the working dir," which is content-free for this
> operation.

I can't argue this one, other than to say that it is a user error, and
users make errors :)  I still prefer --repository and find  --revprop
ugly.

-- 
Philip Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Greg Hudson <gh...@MIT.EDU>.
On Mon, 2002-11-11 at 07:01, Philip Martin wrote:
> How about using --repository and changing the help text to refer to
> "repository property"? 

How is it a repository property?  That suggests a single property list
tied to the entire repository, instead of a property list tied to a
particular revision.  Or it suggests "make this change in the
repository, not in the working dir," which is content-free for this
operation.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 3722 - trunk/subversion/clients/cmdline

Posted by Karl Fogel <kf...@newton.ch.collab.net>.
Philip Martin <ph...@codematters.co.uk> writes:
> How about using --repository and changing the help text to refer to
> "repository property"? 
> 
>    svn ps --repository -r123 svn:log "tag version 0.9"

Mmm, better, yes.

Will wait for a bit more feedback before changing, but so far this
seems like the best option.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org