You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Hong Tang (JIRA)" <ji...@apache.org> on 2009/09/18 04:29:57 UTC

[jira] Created: (MAPREDUCE-1001) Reducing code duplication in Mumak

Reducing code duplication in Mumak
----------------------------------

                 Key: MAPREDUCE-1001
                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1001
             Project: Hadoop Map/Reduce
          Issue Type: Bug
            Reporter: Hong Tang


The first release of Mumak (MAPREDUCE-728) introduces some coupling between the core mapred code with Mumak code. Specifically, New constructors are added to JobTracker and JobInProgress to allow simulator to subclass and alter JT/JIP behavior. This could be a code maintenance overhead when new changes have to be ported to either the added constructors or the simulation subclasses.

It would be nice to refactor the constructors of JobTracker and JobInProgress to avoid as much code duplication as possible.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (MAPREDUCE-1001) Reducing code duplication in Mumak

Posted by "Hong Tang (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAPREDUCE-1001?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12906079#action_12906079 ] 

Hong Tang commented on MAPREDUCE-1001:
--------------------------------------

+1 for fixing it!

> Reducing code duplication in Mumak
> ----------------------------------
>
>                 Key: MAPREDUCE-1001
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1001
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>            Reporter: Hong Tang
>
> The first release of Mumak (MAPREDUCE-728) introduces some coupling between the core mapred code with Mumak code. Specifically, New constructors are added to JobTracker and JobInProgress to allow simulator to subclass and alter JT/JIP behavior. This could be a code maintenance overhead when new changes have to be ported to either the added constructors or the simulation subclasses.
> It would be nice to refactor the constructors of JobTracker and JobInProgress to avoid as much code duplication as possible.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (MAPREDUCE-1001) Reducing code duplication in Mumak

Posted by "Greg Roelofs (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAPREDUCE-1001?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12906039#action_12906039 ] 

Greg Roelofs commented on MAPREDUCE-1001:
-----------------------------------------

Hong's maintenance concerns have been borne out; here's my comment from (duplicate) MAPREDUCE-2024:

bq. The fifth JobTracker constructor (JobTracker(final JobConf conf, Clock clock, boolean ignoredForSimulation)) still uses the old "mapred.*" config settings and appears to duplicate much of the code in the fourth (main) ctor. It should be modernized and, ideally, share as much code as possible with the main one in order to minimize simulation drift and the potential for config errors.

(In case it's not clear, the other constructor has already been modified to use the newer "mapreduce.*" config settings.  Thus the config settings that work for one will have no effect on the other unless they're manually duplicated.)

> Reducing code duplication in Mumak
> ----------------------------------
>
>                 Key: MAPREDUCE-1001
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1001
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>            Reporter: Hong Tang
>
> The first release of Mumak (MAPREDUCE-728) introduces some coupling between the core mapred code with Mumak code. Specifically, New constructors are added to JobTracker and JobInProgress to allow simulator to subclass and alter JT/JIP behavior. This could be a code maintenance overhead when new changes have to be ported to either the added constructors or the simulation subclasses.
> It would be nice to refactor the constructors of JobTracker and JobInProgress to avoid as much code duplication as possible.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.