You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@airavata.apache.org by "Marcus Christie (Jira)" <ji...@apache.org> on 2020/04/23 00:39:00 UTC
[jira] [Comment Edited] (AIRAVATA-3268) BUG: The input file name
cannot be changed using value field content in application interface
[ https://issues.apache.org/jira/browse/AIRAVATA-3268?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17089796#comment-17089796 ]
Marcus Christie edited comment on AIRAVATA-3268 at 4/23/20, 12:38 AM:
----------------------------------------------------------------------
Merge to master/production deployment
- (/) merge airavata-3268 onto airavata master
- merge airavata-3268 onto airavata-django-portal master
- deploy API server
- deploy Helix server
- (/) run database migration
- deploy Django portal
was (Author: marcuschristie):
Merge to master/production deployment
- merge airavata-3268 onto airavata master
- merge airavata-3268 onto airavata-django-portal master
- deploy API server
- deploy Helix server
- run database migration
- deploy Django portal
> BUG: The input file name cannot be changed using value field content in application interface
> ---------------------------------------------------------------------------------------------
>
> Key: AIRAVATA-3268
> URL: https://issues.apache.org/jira/browse/AIRAVATA-3268
> Project: Airavata
> Issue Type: Sub-task
> Components: Django Portal
> Affects Versions: 0.18
> Reporter: Eroma
> Assignee: Marcus Christie
> Priority: Critical
> Fix For: 0.19
>
>
> 1. When creating application inputs in Interface tab user can have the uploading file name changed to the value given in "Value" field.
> 2. This new assigned name will be the one that get added to the job script as well as the name of the file when the file is in the compute resource working directory.
> h5. TODO
> - [x] model/db changes
> - [x] db migration script to copy input.value to input.overrideFilename
> - [x] Django frontend changes
--
This message was sent by Atlassian Jira
(v8.3.4#803005)