You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Henri Yandell <ba...@generationjava.com> on 2002/12/27 09:57:20 UTC

nullFileFilter vs getNullFileFilter


Sorry, lost this email, so unable to reply in-thread.

Collections.synchronisedMap, unmodifiableList etc and the various classes
of these type in Commons [lots in Collections and Lang, for example
ComparatorUtils.reversedComparator()] all seem to use the nullFileFilter
style.

I dunno if precedence counts here, but as its a unique decorator [ie) a
decorator that decorates nothing, a source], it doesn't seem to be an
immediate candidate for Bean style.

Hen

============

From: Jon Scott Stevens <jo...@latchkey.com> Content-type: text/plain;

on 2002/12/25 2:16 PM, "scolebourne@apache.org" <sc...@apache.org>
wrote:

> -        FileFilter filter = new NullFileFilter();
> +        FileFilter filter = FileFilterUtils.nullFileFilter();

This seems like bad naming...shouldn't it be:

FileFilter filter = FileFilterUtils.getNullFileFilter();

?

-jon



--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: nullFileFilter vs getNullFileFilter

Posted by Stephen Colebourne <sc...@btopenworld.com>.
Yes, both [collections] and [lang] now have the java.util.Collections style
of naming in their DEVELOPERS-GUIDE.html file. I would say that this is just
applying the same practice to [io]. Probably should add a DEV-GUIDE to [io]
;-)

Stephen

From: "Henri Yandell" <ba...@generationjava.com>
> Collections.synchronisedMap, unmodifiableList etc and the various classes
> of these type in Commons [lots in Collections and Lang, for example
> ComparatorUtils.reversedComparator()] all seem to use the nullFileFilter
> style.
>
> I dunno if precedence counts here, but as its a unique decorator [ie) a
> decorator that decorates nothing, a source], it doesn't seem to be an
> immediate candidate for Bean style.
>
> Hen
>
> ============
>
> From: Jon Scott Stevens <jo...@latchkey.com> Content-type: text/plain;
>
> on 2002/12/25 2:16 PM, "scolebourne@apache.org" <sc...@apache.org>
> wrote:
>
> > -        FileFilter filter = new NullFileFilter();
> > +        FileFilter filter = FileFilterUtils.nullFileFilter();
>
> This seems like bad naming...shouldn't it be:
>
> FileFilter filter = FileFilterUtils.getNullFileFilter();
>
> ?
>
> -jon
>
>
>
> --
> To unsubscribe, e-mail:
<ma...@jakarta.apache.org>
> For additional commands, e-mail:
<ma...@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>