You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@onami.apache.org by "Mikhail Mazursky (JIRA)" <ji...@apache.org> on 2013/02/26 16:16:16 UTC

[jira] [Created] (ONAMI-94) Refactor locking in ConcurrentLazySingletonScopeImpl

Mikhail Mazursky created ONAMI-94:
-------------------------------------

             Summary: Refactor locking in ConcurrentLazySingletonScopeImpl
                 Key: ONAMI-94
                 URL: https://issues.apache.org/jira/browse/ONAMI-94
             Project: Apache Onami
          Issue Type: Improvement
          Components: scopes
    Affects Versions: scopes-1.0.0
            Reporter: Mikhail Mazursky
            Priority: Minor


- getLock() should be called just before "try", not inside the block - this will also allow to remove null check from releaseLock();
- LockRecord instances may be used as lock objects - no need to create separate objects for that because LockRecord instances are not exposed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira