You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues-all@impala.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2018/11/27 02:02:00 UTC

[jira] [Commented] (IMPALA-7869) Split up parquet-column-readers.cc for readability and compile time

    [ https://issues.apache.org/jira/browse/IMPALA-7869?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16699805#comment-16699805 ] 

ASF subversion and git services commented on IMPALA-7869:
---------------------------------------------------------

Commit 07fd332089c262fa8813605f12b927c8602ac0d2 in impala's branch refs/heads/master from [~tarmstrong@cloudera.com]
[ https://git-wip-us.apache.org/repos/asf?p=impala.git;h=07fd332 ]

IMPALA-7869: break up parquet-column-readers.cc

Move parquet classes into exec/parquet.

Move CollectionColumnReader and ParquetLevelDecoder into separate files.
Remove unnecessary 'encoding_' field from ParquetLevelDecoder.

Switch BOOLEAN decoding to use composition instead of inheritance. This
lets the boolean decoding use the faster batched implementations in
ScalarColumnReader and avoids some confusing aspects of the class
hierarchy, like the ReadValueBatch() implementation on the base class
that was shared between BoolColumnReader and CollectionColumnReader.

Improve compile times by instantiating BitPacking templates in a
separate file (this looks to give a 30s+ speedup for
compiling parquet-column-readers.cc).

Testing:
Ran exhaustive tests.

Change-Id: I0efd5c50b781fe9e3c022b33c66c06cfb529c0b8
Reviewed-on: http://gerrit.cloudera.org:8080/11949
Reviewed-by: Impala Public Jenkins <im...@cloudera.com>
Tested-by: Impala Public Jenkins <im...@cloudera.com>


> Split up parquet-column-readers.cc for readability and compile time
> -------------------------------------------------------------------
>
>                 Key: IMPALA-7869
>                 URL: https://issues.apache.org/jira/browse/IMPALA-7869
>             Project: IMPALA
>          Issue Type: Improvement
>          Components: Backend
>            Reporter: Tim Armstrong
>            Assignee: Tim Armstrong
>            Priority: Major
>              Labels: parquet
>
> [~csringhofer] suggested reorganising the file to be easier to read on https://gerrit.cloudera.org/#/c/8319/
> Compile times are also an issue - this file is the longest pole in the Impala compilation at the moment.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-all-unsubscribe@impala.apache.org
For additional commands, e-mail: issues-all-help@impala.apache.org